account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

Java script not working Xperia X

Learner
Message 1 of 10
1,758 Views
Message 1 of 10

Java script not working Xperia X

Hi! Despite setting Chrome to Java script enabled Java script is not working in my Xperia X. Various websites says that Java script must be enabled. I have seen other threads in this forum but no real solution. Is there any real solution?

Best regards

Thobbe 

9 REPLIES 9
Highlighted
Pioneer
Message 2 of 10
1,747 Views
Message 2 of 10

Re: Java script not working Xperia X

Hi, could you pls provide some example site(s) .  Never had that warning, granted,I use Brave of Firefox, but can't remember seeing it on Chrome either.

 

I'm rather sure JS works, almost any site has a responsive navbar , and those are done in JS, so it surely works.

Learner
Message 3 of 10
1,736 Views
Message 3 of 10

Re: Java script not working Xperia X

Hi!
When I click this link from a mail in my Gmail app in the Xperia X, it says "Enable Java Script in your browser". 
But I now found that if I copy the link and then paste it to Chrome it opens. 
https://valthorens.us2.list-manage.com/track/click?u=219ef832767d74ec6ef2eb42f&id=80e435d26f&e=5abcb...
This also goes for some other links, but these are just not opening from the mail a sub-window opens but then nothing shows. I assumed this was also something with Java Script like the above. 

Best regards
Thobbe

Pioneer
Message 4 of 10
1,731 Views
Message 4 of 10

Re: Java script not working Xperia X

Strange

I tried both Chrome and Firefox and both started the youtube without any delay.

 

It would of course be nice though to know what triggers this "Enable Java Script in your browser"

When you have found out, please share it with us.


who knows knows
who doesn't doesn't
Learner
Message 5 of 10
1,669 Views
Message 5 of 10

Re: Java script not working Xperia X

Hi!

I got this mail with a question if I have a solution for the issues in this thread and the answer is NO!

But I think I again have to clarify: Its ONLY when I click links in mails in mailapps like Gmail the problem occurs and I get the error message that Java Script must be enabled. When I copy the links from the mail to Chrome or other browser they work. 

Best regards
Thobbe

Visitor
Message 6 of 10
1,560 Views
Message 6 of 10

Re: Java script not working Xperia X

I have the same problem with my XZ2. I also have the same problem with Messsge

Emperor
Message 7 of 10
1,556 Views
Message 7 of 10

Re: Java script not working Xperia X

@Dolzy @Thobbe

 

Do you have the latest Chrome update? 

 

have you tested different default browsers ?




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Learner
Message 8 of 10
1,540 Views
Message 8 of 10

Re: Java script not working Xperia X

Hi!
I guess you get the latest Chrome automatically? Its set to automatic update in Google Play. 
Version is 67.0.3396.87.

Is this a known bug in Chrome? 

Best regards
TT

Visitor
Message 9 of 10
1,533 Views
Message 9 of 10

Re: Java script not working Xperia X

Hei. Jeg fikset problemet via Sony Companion på pc. Sikkerhetskopierte alt innhold og tok telefonen tilbake til fabrikkinnstillinger og overførte innholdet tilbake  Nå virker alt som det skal. 

Visitor
Message 10 of 10
1,098 Views
Message 10 of 10

Re: Java script not working Xperia X

You need to disable the Setup Wizard in Settings -> Apps -> (Top right menu_ Show System -> Setup Wizard -> Disable

https://talk.sonymobile.com/t5/Xperia-XZ/Web-link-opens-a-small-window-instead-of-the-standard-brows...