account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Want to know more about Xperia 5? To read more about it go here.
If you can't find the answer to your question there please post it here and let the community help you.

[Bluetooth] No track info on car head unit after Oreo update

Message 1 of 4
Message 1 of 4

[Bluetooth] No track info on car head unit after Oreo update


DSC_0546.JPGBasically it's the same problem described here, but in my case it appeared after I upgraded my XP Dual to Oreo. When streaming music from my phone to my car audio via Bluetooth connection, instead of the current track metadata I'm seeing only an empty screen.  Audio stream is working, as well as next/previous track steering wheel controls. Play/pause button is working only for Pause, Play command is not working.

The solution from the XZ thread doesn't work for me. To be presice it works partially. Downgrading AVCRP to 1.4-1.5 does the trick only for the first song. For any track playing later I get "Unknown" in all metadata fields.

My car is 2013 Mazda CX-5 and I'm using Google Play Music as a music source. I've tried unpairing/repairing several times – no luck. It's very disappointing, that this problem seems to exits for a very long time, and exactly nothing was done to fix this.

Message 2 of 4
Message 2 of 4

Re: [Bluetooth] No track info on car head unit after Oreo update

OK, despite that no one seems to care about that, I'll post a solution that (partially) solved the problem for me:

  1. Turn on Bluetooth
  2. Delete all pairings
  3. Turn off Bluetooth
  4. Go to Settings – Apps & notifications – App info – Three dots menu – Show system
  5. Clean data (not cache) for the Bluetooth, Bluetooth MIDI provider, btidd
  6. Reboot the phone (optional, but recommended)
  7. Go to Settings – System – Developer options (Google how to enable that)
  8. Scroll down to Networking – Bluetooth AVRCP Version. Set it to AVRCP 1.5
  9. Turn on Bluetooth, pair your device


You should be fine now. For older devices you could try to set AVRCP to 1.4.


Sometimes my car still losing it, displaying "Unknown" for all metadata and Play/Pause now working, which can be fixed only by reconnecting the phone. But since the same behaviour was observed under 7.1.1, I'd say it's not worse than before.

One time poster
Message 3 of 4
Message 3 of 4

Re: [Bluetooth] No track info on car head unit after Oreo update

Yes. Works fine for my Audi A3 2015 after 6 months whit problem. Just change back to AVRCP 1.5

Thanks for help. 

Message 4 of 4
Message 4 of 4

Re: [Bluetooth] No track info on car head unit after Oreo update


I had same issue on PIE and your solution solved the problem. Thanks