account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Beats Tour 2 Problem - X Performance

Highlighted
Learner
Message 1 of 4
2,265 Views
Message 1 of 4

Beats Tour 2 Problem - X Performance

Hi, I need your help. A few days ago I bought a Tour2 Beats In-Ear Headphones. I tried to use it with my Sony Xperia X Performance (Android 7.0) but the connection is lost after a few seconds between the phone and the headset.  I also tried the headphone with my company phone Sony Xperia XA (Android 6.0) and it worked absolute correctly. I tried re-installing X Performance with Sony Companion and also hard resetting, but nothing helped. Do you have any idea which would be a solution?

3 REPLIES 3
Emperor
Message 2 of 4
2,264 Views
Message 2 of 4

Re: Beats Tour 2 Problem - X Performance

@DaWeD

 

Could you test teh phone in safe mode and reset the headphones.




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Learner
Message 3 of 4
2,257 Views
Message 3 of 4

Re: Beats Tour 2 Problem - X Performance

Yes, We also tired that way... but it doesn't worked.

Unregistered user
Not applicable
Message 4 of 4
2,248 Views
Message 4 of 4

Re: Beats Tour 2 Problem - X Performance


@DaWeD wrote:

Hi, I need your help. A few days ago I bought a Tour2 Beats In-Ear Headphones. I tried to use it with my Sony Xperia X Performance (Android 7.0) but the connection is lost after a few seconds between the phone and the headset.  I also tried the headphone with my company phone Sony Xperia XA (Android 6.0) and it worked absolute correctly. I tried re-installing X Performance with Sony Companion and also hard resetting, but nothing helped. Do you have any idea which would be a solution?


In Beats by Dr Dre is written that Tour 2 is: "Compatible with Apple iOS devices but varies with other brands or products", so maybe Tour 2 is not supported with your X Performance or Nougat, so that's why working incorrectly, try to connect with other X Performance if you have opportunity, to see something wrong is with your X Performance or really Tour 2 is not compatible with this model or maybe Nougat Slightly smiling Face But that's just my guess about support, reason can be other, typically if headphones is supported they working right (even new)) Slightly smiling Face