account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Accelerometer stops working

SOLVED
Learner
Message 191 of 411
1,290 Views
Message 191 of 411

Re: Accelerometer stops working

I've the same issue
Apprentice
Message 192 of 411
1,266 Views
Message 192 of 411

Re: Accelerometer stops working

Same here (in The Netherlands).

Tried disabeling several apps etc, but no result.

 

Contacted Sony Care, they advised a factory reset (not sure if that will work since several people in this forum already tried this).

 

Does/will Sony respond in this forum ?

 

Adviser
Message 193 of 411
1,207 Views
Message 193 of 411

Re: Accelerometer stops working

Hi,

 

I followed the steps as described by ianchen1967. I did this on Friday afternoon and up to now, all is working fine.


ianchen1967 wrote:
Below solution works so far after five days's trial. No functions and apps need to be disabled.

You should remember your google account and password before going.

(1) go to Settings - Apps - App Google, press Disable, this will unstall App Google from your phone, and no need to install factory version.
(2) go to Settings - Account & sync, press Google and click right-top corner to open menu, press Remove account.
(3) Restart your phone.
(4) Enter Google play store, you will be requested to login your Google account. Do it.
(5) Search App Google in Google play and install up-to-date version of this App, then open/enable App Google. Done.

Adviser
Message 194 of 411
1,165 Views
Message 194 of 411

Re: Accelerometer stops working

Any confirmation if it's a hardware or software problem?
One time poster
Message 195 of 411
1,152 Views
Message 195 of 411

Re: Accelerometer stops working

not so fast!

It`s may be 3-24 hours fo testing...

Inhabitant
Message 196 of 411
1,137 Views
Message 196 of 411

Re: Accelerometer stops working


@Fonteynb wrote:

Hi,

 

I followed the steps as described by ianchen1967. I did this on Friday afternoon and up to now, all is working fine.


@ianchen1967 wrote:
Below solution works so far after five days's trial. No functions and apps need to be disabled.

You should remember your google account and password before going.

(1) go to Settings - Apps - App Google, press Disable, this will unstall App Google from your phone, and no need to install factory version.
(2) go to Settings - Account & sync, press Google and click right-top corner to open menu, press Remove account.
(3) Restart your phone.
(4) Enter Google play store, you will be requested to login your Google account. Do it.
(5) Search App Google in Google play and install up-to-date version of this App, then open/enable App Google. Done.


Not the solution , at least for me...

Luigi P
Adviser
Message 197 of 411
1,128 Views
Message 197 of 411

Re: Accelerometer stops working

Didn't work for me either
Regular
Message 198 of 411
1,084 Views
Message 198 of 411

Re: Accelerometer stops working

I hope Sony guys are checking this thread.

I can provide logcat where a sensorservice error can be found.

Screenshot_20161024-150229.png

One time poster
Message 199 of 411
1,079 Views
Message 199 of 411

Re: Accelerometer stops working

I notice that my accelerometer stops working when I open the camera. After I close the camera, I can no longer use the accelerometer and gyro and the diagnostic tool fails for those tests until I reboot.

 

EDIT: Well, I thought it was the camera, but I rebooted this morning and didn't use my camera and now it's not working again. Now I'm not sure what's causing the issue.

Learner
Message 200 of 411
794 Views
Message 200 of 411

Re: Accelerometer stops working

Same issue on my x performance f8131. Android 6.0.1. Build no. 35.0.A.1.282.

Contacted Sony support AU. Did the software repair, but will only work for an hour or so.

I reboot, open album to make sure it's working, come back and hour or so later, after not opening any apps, open my album, and surprise surprise, not working.