account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Want to know more about Xperia 5? To read more about it go here.
If you can't find the answer to your question there please post it here and let the community help you.

Proximity sensor won't work after disassembling

Highlighted
One time poster
Message 1 of 1
67 Views
Message 1 of 1

Proximity sensor won't work after disassembling

Hi Sony community!

 

I recently got the Sony Xperia X Compact of my cousin. When I got the phone, everything was working well except the audio jack. So I bought a new one and replaced the audio jack myself. I have a lot of experience in repairing phones and think I know what I'm doing.

 

The problem: After dis-, and reassembling the phone my proximity sensor won't work anymore. I double-checked the connection between the sensor flex cable and the main board, but I am sure I have put it in correctly. I never at all touched or moved the sensor itself (I did not replace the screen!). The strangest part of the story: the ambient light sensor (which is the SAME electronic part) is still working...

 

I also found one guy on XDA and one on YouTube having the same issue after plugging out the sensor flex cable from the mother board. So I assume it's a problem of the socket for the flex cable on the main board, maybe a very fragile connection or something? Does anybody have the same problem or a solution? :/