account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Want to know more about Xperia 5? To read more about it go here.
If you can't find the answer to your question there please post it here and let the community help you.

How to disable fingeprint sensor?

SOLVED
Highlighted
Adviser
Message 1 of 9
4,225 Views
Message 1 of 9

How to disable fingeprint sensor?

Honestly, fingerprint sensor on the power button was a bad idea

 

I use pin unlock and not finger, so fingerprint sensor on the power button is very annoying thing to me. When I turn on the screen just to read the notification or see the clock, my finger remains on the power button which triggers the PIN prompt. But all I want is to read notification on the screen, not to unlock the phone.

 

Can I disable fingeprint sensor completely so it never triggers unlock and never prompts me to enter PIN when I'm turing screen to see the clock?

 

Thank you

1 ACCEPTED SOLUTION

Accepted Solutions
Adviser
Message 9 of 9
5,346 Views
Message 9 of 9

Re: How to disable fingeprint sensor?

Update

After recent OTA update the behavior has changed.

Now, when I press the power button and keep my finger on the sensor it does not trigger the unlock PIN prompt. It just shows me the screen. I have to rise my finger and touch the sensor again to trigger PIN prompt.

This is what I actually wanted from the beggining. Issue resolved

8 REPLIES 8
Sony Xperia Support
Message 2 of 9
4,217 Views
Message 2 of 9

Re: How to disable fingeprint sensor?

Hi @selenX and welcome to the community.

 

I'm afraid there is no such setting. When you put your finger on the power button it will register the same command as when you swipe just on your screen to unlock it.

 

Let me know if there is anything else you are wondering about.

 


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

Adviser
Message 3 of 9
4,215 Views
Message 3 of 9

Re: How to disable fingeprint sensor?

This was kinda expected answer. But do you know any hard way to disable it? Root the device? Physically replace power button? I don't care about my warranty as I'm already very disappointed with this model and want it to die asap

Emperor
Message 4 of 9
4,201 Views
Message 4 of 9

Re: How to disable fingeprint sensor?

@selenX

 

You could flash the US firmware, that will disable the fingerprint sensor. 




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

If1
Learner
Message 5 of 9
4,190 Views
Message 5 of 9

Re: How to disable fingeprint sensor?

>I turn on the screen just to read the notification or see the clock, my finger remains 

Simply don't register your fingers or register your foot finger Winking Face

When you press power button tiny message "not recognised" on

the bottom screen will appear. It should not be so annoying.

 

I'm using compatible cover with X compact:

* when I open cover, phone avtomatically display clock and messages info

* if I want to unlock I simply touch power button - very handy (the best position)

 

Why are you so dissapointed with phone ?

Before I buy phone, I always  read specification, look and test it in the shop, read tests, forums...

I buy phone that best suits me.

 

Regards

 

 

Adviser
Message 6 of 9
4,145 Views
Message 6 of 9

Re: How to disable fingeprint sensor?

What is the downside of flashing US firmware for EU phone? Will that affect available frequencies? Warranty?

Adviser
Message 7 of 9
4,143 Views
Message 7 of 9

Re: How to disable fingeprint sensor?

I did not register any fingerprint. But I have enable PIN unlock. This way as soon as you touch the power button the screen will show you PIN unlock keyboard which covers entire the screen, so you can't see neither Clock nor Notifications

 

I read a lot about this phone. If there were a review saying that you won't be able to disable the fingerprint sensor and it will keep annoying you even if you have no fingers registered - beleive me I would not buy it

Enthusiast
Message 8 of 9
4,130 Views
Message 8 of 9

Re: How to disable fingeprint sensor?

I wonder if this really has to do with the fingerprint sensor. As far as I remember what you describe was the usual behaviour of the Z3 Compact when it started. Only with a later firmware update an additional swipe was introduced to get to the PIN unlock screen and a lot of people then complained about this additional swipe they had to do ...

 

Anyway, perhaps you can try the following, his works with my X Compact:

Activate(!) fingerprint sensor and store the fingerprint of a finger that you usually don't use to press the power button (maybe the little finger of your left hand ...). If you now press the power button with any other finger you should end up in the lock screen with clock and notifications as you want it to have. A swipe up activates the PIN unlock screen if needed.

For me I am using the fingerprint sensor to unlock my phone but I use one of my "unstored" fingers if I just want to access the lock screen if i I want to.

Adviser
Message 9 of 9
5,347 Views
Message 9 of 9

Re: How to disable fingeprint sensor?

Update

After recent OTA update the behavior has changed.

Now, when I press the power button and keep my finger on the sensor it does not trigger the unlock PIN prompt. It just shows me the screen. I have to rise my finger and touch the sensor again to trigger PIN prompt.

This is what I actually wanted from the beggining. Issue resolved