account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

Google Play Service not working properly

One time poster
Message 1 of 4
1,296 Views
Message 1 of 4

Google Play Service not working properly

When I try to download or update a software in Google play, it will download to 100% and then stop there without installation. It will continue after I restart the Google play. The problem also affects the notification of some software. 

3 REPLIES 3
Inhabitant
Message 2 of 4
1,282 Views
Message 2 of 4

Re: Google Play Service not working properly

I've also had this problem on and off for two to three weeks (and I updated to Nougat 7.1.1 a few days ago - and the problem persists).

 

Kroma

Sony Xperia Support
Message 3 of 4
1,267 Views
Message 3 of 4

Re: Google Play Service not working properly

Hi @TBian,

 

Welcome to the community! 

 

Sorry to hear that Slightly frowning Face

 

Can you go to settings > apps > Google Play Store > force stop > storage > clear data 

 

Once you have tried the above restart the phone and see if you experience the same issue. 

 

Let me know Slightly smiling Face


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

Highlighted
Inhabitant
Message 4 of 4
1,255 Views
Message 4 of 4

Re: Google Play Service not working properly

I did all that a couple of weeks ago along with rolling back to a previous version etc.  The problem persisted.  I'm back on the current version now and it still happens on occasion. Having searched online soon after it started, it seems to be a common thing.  I'm sure it will sort itself out.

 

K