account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 

Accepted Solutions makes a difference!

Did you know that by clicking the Accept as Solution button You will help other people visiting the community to find their answer? Learn more.

Psst - What do you think about our community? Take a moment and share your thoughts around this community by doing this short survey.

Boot loop

SOLVED
Learner
Message 1 of 3
956 Views
Message 1 of 3

Boot loop

Ok so some history

My Xperia U (ST25i) is completely stock on the most up to date software etc. I bought it in the UK.

I was using it as normal (Yes I still use this old phone daily) until it wouldn't open apps. They would just black screen then close.

So I decided to restart my phone by holding the power button and then pressing shut down.

I then turned it back on.

And now its got boot loop syndrome. It will show the Sony logo then the Xperia logo, then it will freeze for about 2 seconds then repeat the process again.

 

What I've tried so far

I have tried using Xperia companion to repair the device.

It wouldn't recognise it at all. The computer will beep to let me know something was plugged in, then it will beep to tell me it was unplugged every time it restarts.

 

I have removed the battery and tried it.

same thing

holding vol down when plugging in had the same results.

I' have tried a flash tool but the flash tool couldn't find the file I down loaded so I didn't get very far with that.

I have read soloutions to this problem but links were expired or they didnt work.

 

Have any ideas on how to fix this?

I don't want to "just get a new phone" because I have some important data on it still and I want to at least recover it.

 

Thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions
Learner
Message 3 of 3
933 Views
Message 3 of 3

Re: Boot loop

Update!

I cliked flashmode again in the flash tool and my phone randomly entered flashmode after a while on its own.

I donwloaded a different version of the ftf file and flashed it. This is what happened:
16/018/2018 19:18:03 - INFO - Device connected in flash mode
16/018/2018 19:18:23 - INFO - Selected ST25i / 6.1.1.B.1.10 / O2CZ
16/018/2018 19:18:23 - INFO - Preparing files for flashing
16/018/2018 19:18:39 - INFO - Please connect your device into flashmode.
16/018/2018 19:18:40 - INFO - Opening device for R/W
16/018/2018 19:18:40 - INFO - Reading device information
16/018/2018 19:18:45 - INFO - Unable to read from phone after having opened it.
16/018/2018 19:18:45 - INFO - trying to continue anyway
16/018/2018 19:18:45 - INFO - Start Flashing
16/018/2018 19:18:45 - INFO - Processing loader
16/018/2018 19:18:45 - INFO - Checking header
16/018/2018 19:18:46 - INFO - Ending flash session
16/018/2018 19:18:46 - ERROR - Error in processHeader : 995 : The I/O operation has been aborted because of either a thread exit or an application request.
16/018/2018 19:18:46 - ERROR - Error flashing. Aborted
16/018/2018 19:18:46 - INFO - Device disconnected
16/019/2018 19:19:01 - INFO - Device connected with USB debugging off
16/019/2018 19:19:01 - INFO - For 2011 devices line, be sure you are not in MTP mode

Then my phone randomly turned itself on again and it is still powering on as I speak.

hang on its on now!!!

It came up with the first time set up stuff and it seems to work now!

 

So I guess the soloution was to just wait for it to fix its self somehow Face with stuck-out Tongue

No idea what happened or how it happened but it works now.

Only problem is it is at 1%charge for some reason :/

2 REPLIES 2
Learner
Message 2 of 3
948 Views
Message 2 of 3

Re: Boot loop

Ok so I managed to unlock the bootloader and I started to flash it in flashtool but I ran into a problem.

This is the problem that happened during the flash:

16/044/2018 18:44:32 - INFO - Unable to read from phone after having opened it.
16/044/2018 18:44:32 - INFO - trying to continue anyway
16/044/2018 18:44:32 - INFO - Start Flashing
16/044/2018 18:44:32 - INFO - Processing loader
16/044/2018 18:44:32 - INFO - Checking header
16/044/2018 18:44:32 - INFO - Ending flash session
16/044/2018 18:44:32 - ERROR - Error in processHeader : 22 : The device does not recognize the command.
16/044/2018 18:44:32 - ERROR - Error flashing. Aborted
16/044/2018 18:44:33 - INFO - Device disconnected

 

And now it wont even attempt to turn on or anything. Won't go into flash mode anymore, won't go into fastboot mode either. The only thing I can get the phone to do now is show me a little red light when I plug it in to something. Thats all. Nothing more, nothing less. Just a single red led near the top of the phone.

 

Can this be fixed or is it 100% dead now?

Learner
Message 3 of 3
934 Views
Message 3 of 3

Re: Boot loop

Update!

I cliked flashmode again in the flash tool and my phone randomly entered flashmode after a while on its own.

I donwloaded a different version of the ftf file and flashed it. This is what happened:
16/018/2018 19:18:03 - INFO - Device connected in flash mode
16/018/2018 19:18:23 - INFO - Selected ST25i / 6.1.1.B.1.10 / O2CZ
16/018/2018 19:18:23 - INFO - Preparing files for flashing
16/018/2018 19:18:39 - INFO - Please connect your device into flashmode.
16/018/2018 19:18:40 - INFO - Opening device for R/W
16/018/2018 19:18:40 - INFO - Reading device information
16/018/2018 19:18:45 - INFO - Unable to read from phone after having opened it.
16/018/2018 19:18:45 - INFO - trying to continue anyway
16/018/2018 19:18:45 - INFO - Start Flashing
16/018/2018 19:18:45 - INFO - Processing loader
16/018/2018 19:18:45 - INFO - Checking header
16/018/2018 19:18:46 - INFO - Ending flash session
16/018/2018 19:18:46 - ERROR - Error in processHeader : 995 : The I/O operation has been aborted because of either a thread exit or an application request.
16/018/2018 19:18:46 - ERROR - Error flashing. Aborted
16/018/2018 19:18:46 - INFO - Device disconnected
16/019/2018 19:19:01 - INFO - Device connected with USB debugging off
16/019/2018 19:19:01 - INFO - For 2011 devices line, be sure you are not in MTP mode

Then my phone randomly turned itself on again and it is still powering on as I speak.

hang on its on now!!!

It came up with the first time set up stuff and it seems to work now!

 

So I guess the soloution was to just wait for it to fix its self somehow Face with stuck-out Tongue

No idea what happened or how it happened but it works now.

Only problem is it is at 1%charge for some reason :/