account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 

Accepted Solutions makes a difference!

Did you know that by clicking the Accept as Solution button You will help other people visiting the community to find their answer? Learn more.

Psst - What do you think about our community? Take a moment and share your thoughts around this community by doing this short survey.

Walkman or firmware bug?

SOLVED
Visitor
Message 1 of 5
761 Views
Message 1 of 5

Walkman or firmware bug?

I own xperia SP C5302
My current walkman version is 8.4.A.1.4
and android build 12.1.A.1.205

My music files were nicely tagged and I had several playlists & favorites on my walkman. All audio files are stored in Sandisk ultra 32gb card.

Few hours ago, my walkman went wrong. all artist name tags was changed to "Unknown artist", playlists were gone, and walkman favorite folder became empty. Currently I'm unable to open the song list from artist submenu, artist potrait is blank (no icon at all, unlike untagged one) and artist name also blank (no text telling unknown artist or sort of it)

Song title, album title, track number, and other tags including cover artwork are fine.

I dont know what was happened earlier, I was doing unmount sdcard safely from storage setting for sdcard hot swap, and returned it back short after.
And I remember the battery level was around 10%.

Is there anyone experiencing the same problem? or anyone got any clue what was trigger this bug?
Thanks in advance
1 ACCEPTED SOLUTION

Accepted Solutions
Commissioner
Message 2 of 5
930 Views
Message 2 of 5

Re: Walkman or firmware bug?

It ever happened to me once.

1. Unmount your SD cards.
2. Go to Settings > Apps > Walkman > Clear Chace dan Clear Data.
3. Reboot/Turn off your phone.
4. Turn the phone on dan then re-make your Playlist. Artist name tags should be back to normal again.

Hope this helps.

View solution in original post

4 REPLIES 4
Commissioner
Message 2 of 5
931 Views
Message 2 of 5

Re: Walkman or firmware bug?

It ever happened to me once.

1. Unmount your SD cards.
2. Go to Settings > Apps > Walkman > Clear Chace dan Clear Data.
3. Reboot/Turn off your phone.
4. Turn the phone on dan then re-make your Playlist. Artist name tags should be back to normal again.

Hope this helps.

View solution in original post

Visitor
Message 3 of 5
685 Views
Message 3 of 5

Re: Walkman or firmware bug?

Hi 3xperia, thanks for your guide.
I've tried to do the exact steps but all artist still tagged as "Unknown artist" and can't open artist list.
I also tried to clear data, reset walkman to factory default, and reinstall the update, then reboot. Still n,o good signs.
And funny thing is whenever I try to tag an artist name from walkman, results two songs (plus another random song) are tagged.
Most likely all my music files are corrupted.
Visitor
Message 4 of 5
652 Views
Message 4 of 5

Re: Walkman or firmware bug?

Problem solved!
3xperia solution actually works, but need another additional step: locate and rename audio files folder.
Seems the audio library cache was stuck somewhere on root.
Highlighted
Commissioner
Message 5 of 5
480 Views
Message 5 of 5

Re: Walkman or firmware bug?

You're welcome, man. Glad I could help.