account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 

Accepted Solutions makes a difference!

Did you know that by clicking the Accept as Solution button You will help other people visiting the community to find their answer? Learn more.

Psst - What do you think about our community? Take a moment and share your thoughts around this community by doing this short survey.

Unable to Encrypt phone while activating exchange activesync

SOLVED
Message 1 of 30
10,501 Views
Message 1 of 30

Unable to Encrypt phone while activating exchange activesync

Hi Everyone,

I am using Xperia S and my corporate e-mail account has stopped working post the Jelly Bean update for Xperia S. I was able to use mail (exchange Active sync) before on ICS without problem however it stopped immediately after the update.

While activating active Sync it asks for device activation and then stay on it for ages and doesn't complete which is why i am unable to activate my corporate email on my phone. I have checked with the IT team and they have confirmed that the active sync is activated from the background and i should be able to setup email.

Please help

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Sony Xperia Support
Message 9 of 30
7,073 Views
Message 9 of 30

Re: Unable to Encrypt phone while activating exchange activesync

This problem will be fixed in an upcoming update for the phone with version number 6.2.B.1.xx.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

29 REPLIES 29
Message 2 of 30
5,640 Views
Message 2 of 30

Re: Unable to Encrypt phone while activating exchange activesync

Hi Mathur

I had exactly the same issue when I upgraded my device to .200, created this post myself.

http://talk.sonymobile.com/message/49669

One time poster
Message 3 of 30
5,640 Views
Message 3 of 30

Re: Unable to Encrypt phone while activating exchange activesync

Hi Mathur Aashish,

I had the same problems with the exchange ActiveSnyc after Android Update 4.2.2 on my Xperia Z.

I tried a lot without success - at the end, the solution was the following:

My settings for "Auto-sync data" in the phone's "Data usage" were off and that prevents the Exchange sync from setting up the Mail-App as a device administrator. When you set up an Exchange account, after the page where it asks you to name the account, it should display a "Activate device administrator?" screen, where you grant permission for the Email app to wipe your phone, set password rules, etc... If "Auto-sync data" is disabled, that screen is skipped, and the Device administrator never gets set up. You can check this by going to Settings -> Security -> Device administrators. If "Email" isn't listed there, Exchange sync won't work. 

You can turn auto sync on/off by going to Settings - Data Usage and then pressing the '...' more menu button at the top.

Good luck and best regards

Patrick

Sony Xperia Support
Message 4 of 30
5,640 Views
Message 4 of 30

Re: Unable to Encrypt phone while activating exchange activesync

That sounds strange. From what i can see Xperia S still doesn't support encryption so it should not try to encrypt the phone. Could you please send me a PM with the following information and i'll forward this for further investigation:

Name:

Phone nr:

E-mail:

Country:

Operator:

IMEI nr:

Build number:

Exchange version:

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Visitor
Message 5 of 30
5,640 Views
Message 5 of 30

Re: Unable to Encrypt phone while activating exchange activesync

Hi Everyone,

I have changed my Xperia S to Xperia SL, but I can't activate the Email via Exchange AciveSync.

I set the incoming setting and I activated the server request for remote control.os security features.

After I approve the "Encrypt phone". Then, the initial screen of the robot, but does nothing more.

I tried again and again, and I tried after restoring the factory setting.

The data are as follows:

Name:     Janos SÓVÁGÓ

E-mail:     sovago.janos@gmail.com

Country:     Hungary

Operator:     Telenor

IMEI nr.:     35361705-659595-6

Build nr.:     6.2.B.0.211

Exchange version:     2003

Remark: Another type of phones (HTC, Samsung) that work with the server.

If anyones knows, please helps.

Best Regards

Janos

One time poster
Message 6 of 30
5,640 Views
Message 6 of 30

Re: Unable to Encrypt phone while activating exchange activesync

@Rickard,

You are making jokes, right? Sound Strange?

I have registered this issue on May 31st and you have never seen it?

I have even post the screenshots and got the feedback from Johan that the Xperia team is working on the case.

http://talk.sonymobile.com/message/477252#477252

It does not encrypt, only the JB implemented by Xperia have the feeds from the encryption apk in app/system folder.

Go talk to Johan please.

One time poster
Message 7 of 30
5,640 Views
Message 7 of 30

Re: Unable to Encrypt phone while activating exchange activesync

And you will never achieve the full encryption. Sony implemented the encryption in a half-way.

You want to have the corporate emails in your XperiaS? go back to ICS.

Sony Xperia Support
Message 8 of 30
5,640 Views
Message 8 of 30

Re: Unable to Encrypt phone while activating exchange activesync

Thanks for pointing me to that thread!

I've been away for vacation and parental leave for 2 months and Johan is now on vacation so i have unfortunately not seen this issue before.

I found Johans escalation and the information in that thread is correct, this issue will be fixed in an upcoming update named 6.2.B.1.xx.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Highlighted
Sony Xperia Support
Message 9 of 30
7,074 Views
Message 9 of 30

Re: Unable to Encrypt phone while activating exchange activesync

This problem will be fixed in an upcoming update for the phone with version number 6.2.B.1.xx.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Visitor
Message 10 of 30
5,640 Views
Message 10 of 30

Re: Unable to Encrypt phone while activating exchange activesync

Hi Rickard,

the first of all I thanks your answer.

Do you know or what do you think when can we expect the new build version?

BR

Janos