account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 

Accepted Solutions makes a difference!

Did you know that by clicking the Accept as Solution button You will help other people visiting the community to find their answer? Learn more.

Psst - What do you think about our community? Take a moment and share your thoughts around this community by doing this short survey.

Call goes to speaker automatically

SOLVED
Message 11 of 42
11,316 Views
Message 11 of 42

Re: Call goes to speaker automatically

I have tried all the suggestions posted here. Then I tested calling from another phone. Out of five tries, two calls went straight to the speaker! This is a serious problem. It is an issue that Sony must look into. It's not some random bug that can be cured by hard reset or other first-aid measures as all well-meaning people here have suggested. I was thinking of upgraing to a high-end Xperia handset, now I will reconsider my decision, considering even the Z series are having this weird problem.

 

But one thing I am certain about is that the issue started after the JB 4.3 update for SP. Now I have to live with this. While taking public transport or at the meeting room in office when I answer my call it is embarrasing to hear a voice in the speaker suddenly. 

Message 12 of 42
11,300 Views
Message 12 of 42

Re: Call goes to speaker automatically

Chrome latest update for Android is the culprit folks! Those who are having this problem, just disable chrome, restart your phone and test it. Try calling from another handset, and you will get five out of five calls not going to the speaker. My issue got resolved after I disabled Chrome.

 

One guy on another thread had mentioned the Chrome thing, after which I got a hint. The problem did start after the latest JB 4.3 for SP update along with the Chrome update. But I hate to see Chrome go. Switching to Firebox for Android now.

Commissioner
Message 13 of 42
11,295 Views
Message 13 of 42

Re: Call goes to speaker automatically

@desertfox52001

what the h....

Are you sure?

Highlighted
Talent
Message 14 of 42
11,281 Views
Message 14 of 42

Re: Call goes to speaker automatically

Same problem here. Not all calls but some of them go straight to speaker.

 

This started some time after updating to 4.3, together with serious lagging. Have tried to force to factory settings, have fixed software with Bridge, have reset all the apps. Nothing has helped.

 

Haven't tried to disable Chrome, though. I wonder what does it have to do with the call app.

 

Message 15 of 42
27,941 Views
Message 15 of 42

Re: Call goes to speaker automatically

Yeah, try it to believe it. I am no expert but I did notice that Chrome (before the update) had an option that read something like "let websites have access to audio/camera". After the update this option is missing. Maybe the speaker thing has got something to do with it. I guess a Sony ninja can give a better answer.

 

But after trying A to Z all the advice posted here, I disabled Chrome (because the problem I remember started after the update, both 4.3 + Chrome).

 

Do this:

 

1) Disable Chrome

2) Restart phone

3) Try calling your phone from another number.

4) Answer.

5) Now it won't go to the speaker directly as it used to

 

Earlier when the problem persisted, I noticed that the first call after a period of time when the phone was switched off and switched on, always went to the speaker. This has not happened since I disabled Chrome.

 

I have tried ringing my phone 20 times with a gap of three minutes each. All of them came up right -- no more routing to the speaker. hurray!

 

But, what the ... Chrome exactly did to my phone?

 

 

Commissioner
Message 16 of 42
11,184 Views
Message 16 of 42

Re: Call goes to speaker automatically

Well desertfox52001 I owe you a kudo.

I've tried the solution from Alexdon as it seemed to work for a while, but after some time the problem still persist.

So I disabled chrome (unfortunately I cannot uninstall it) and switched to dolphin browser.

It works!!!!

And I like dolphin browser!!

Thank you man!

Talent
Message 17 of 42
11,148 Views
Message 17 of 42

Re: Call goes to speaker automatically

Disabling Chrome really does the trick! At least for a while but looks promising. Thanks!

Commissioner
Message 18 of 42
11,141 Views
Message 18 of 42

Re: Call goes to speaker automatically

YES!!!

KUDO to desertfox52001!

One time poster
Message 19 of 42
11,125 Views
Message 19 of 42

Re: Call goes to speaker automatically

Just uninstall chrome updates
Moderator
Message 20 of 42
11,121 Views
Message 20 of 42

Re: Call goes to speaker automatically

But has any of you tried only uninstalling updates for chrome and not disabling?



Moderators are not affiliated with, or work for Sony Mobile, and their posts represent their own opinions and views. Click here to find out more about the different roles on the community.