account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Want to know more about Xperia 5? To read more about it go here.
If you can't find the answer to your question there please post it here and let the community help you.

Wifi with exclamation sign and 3g at the same time, but no data connection regulary

SOLVED
Learner
Message 1 of 6
394 Views
Message 1 of 6

Wifi with exclamation sign and 3g at the same time, but no data connection regulary

I have a M4 aqua E2303, build number 26.1.A.2.99. But after some time using it it begins doing something strange. Pretty often the status bar shows an exclamation at the wifi sign and in the meantime also 3g showing up. Usualy i only see wifi or 3g and sometimes only the wifi with an exclamation sign. When wifi and 3g are in sight togheter i dont have a data-connection at all, and i cannot enter the wifi settings (blank screen when trying to open it and back button does not react. The only way to fix it i found was rebooting. 

I see very often an autification error for all 4 wifi networks i use, but some more than another. I allready tried to change the frequency band of the wifi, but it did not succeed. What could this be?

 

Furthermore i have some problems with my SD card which is sometimes not seen by my phone, and again rebooting worked, unless one time, so i had to reinstall half of the apps on my sd card. Maybe this is related to it?

I also found out that only when my SD card is inserted and working (it didn't work when i lost my apps, even when i rebooted), it sais 'upgrading android' at the end of starting up. 

My phone even did restart a couple of times after the day my SD card failed, just random from being on to starting up (no shuttng down) and i did not have to fill in my pincode, which is weird i think

1 ACCEPTED SOLUTION

Accepted Solutions
Emperor
Message 3 of 6
563 Views
Message 3 of 6

Re: Wifi with exclamation sign and 3g at the same time, but no data connection regulary

@dutchstudent

 

Your SD card might be acting up or faulty, you could backup everything and reformat the SD card. Also, how far are you from the router? 




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

5 REPLIES 5
Highlighted
Genius
Message 2 of 6
375 Views
Message 2 of 6

Re: Wifi with exclamation sign and 3g at the same time, but no data connection regulary

Hi @dutchstudent

 

Please, try first run a backup of the device information as explained here. Then perform a system repair using PC Companion or Bridge for MAC. This will factory reset your phone and erase all data. You might need to charge your device for about 1-2 hours before so the device has at least 80% battery. Make sure the device is not connected to computer or laptop and turned off until you are prompted (sometimes you have to press power button and volume up until the device vibrates 3 times or on some devices you have to press the small button near the SIM tray or on the back of the device). Start PC Companion -> Support zone -> Update my phone/tablet -> Blue Repair my phone/tablet -> follow instructions. When prompted connect your phone still switched off holding volume down or back button. The repair or reformat process will start. If you are using Windows 8/8.1 or a 64 bit operating system adjust settings for PC Companion and run in compatibility mode -> chose Windows 7 or XP. Please, keep us updated.

"We can have anything we want on life, if we just help others to found what they need” - Ebelsain Villegas
Emperor
Message 3 of 6
564 Views
Message 3 of 6

Re: Wifi with exclamation sign and 3g at the same time, but no data connection regulary

@dutchstudent

 

Your SD card might be acting up or faulty, you could backup everything and reformat the SD card. Also, how far are you from the router? 




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Learner
Message 4 of 6
327 Views
Message 4 of 6

Re: Wifi with exclamation sign and 3g at the same time, but no data connection regulary

The problem did not uccur yet after reformating the SD, so it might be the solution. If it happens again or someting else and i've got time, i'll try to repair my phone

Emperor
Message 5 of 6
311 Views
Message 5 of 6

Re: Wifi with exclamation sign and 3g at the same time, but no data connection regulary

@dutchstudent

 

keep us updated. 




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

One time poster
Message 6 of 6
266 Views
Message 6 of 6

Re: Wifi with exclamation sign and 3g at the same time, but no data connection regulary

I THINK I DO HAVE THE SAME PROBLEM HERE. I HAVE SONY XPERIA M2 AQUA. PRIOR TO LOLLIPOP THE  ORIGINAL OS WAS KITKAT. RIGHT AFTER THE UPDATE I CANNOT CONNECT TO THE INTERNET (DATA) USING MY SIM PROVIDER. I DONT KNOW WHAT HAPPENED BUT BY DATA PROVIDER STATED THAT THERE IS NO PROBLEM WITH THE NETWORK. CAUSE EVEN THOUGH I ACTIVATE MY DATA IT DOESNT EVEN SHOWING ANY LETTERS LIKE "E" OR "H" ON MY PHONE. I'M JUST WONDERING IF THERE MIGHT BE A PROBLEM RIGHT AFTER MY OS WAS UPDATED.