account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

SIM1 gets disable - please help

Regular
Message 1 of 20
3,433 Views
Message 1 of 20

SIM1 gets disable - please help

For several weeks I have been facing a very annoying issue with my M4 dual sim. At least once a day the device looses SIM1 connection, the icon disappears, no way to enable it again unless restarted. This would not be bad enough but if left all incoming calls are redirected to the 2nd SIM and charges occur as I am on roaming with the latter one. Mobile data SIM preference is also automatically changed to the 2nd SIM. I have done factory resets, no success. It drives me crazy, never thought Sony can make such a bad device (not mentioning here the stupid misselection of the SIM you want to use on car Bluetooth system)
19 REPLIES 19
Highlighted
Message 2 of 20
3,424 Views
Message 2 of 20

Re: SIM1 gets disable - please help

Just happened suddenly? Did you update firmware or drop your phone to the ground or anything?
Emperor
Message 3 of 20
3,420 Views
Message 3 of 20

Re: SIM1 gets disable - please help

@Trialbyfire

 

The problem might be a faulty/old SIM card, what if you get a new SIM card?




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Regular
Message 4 of 20
3,407 Views
Message 4 of 20

Re: SIM1 gets disable - please help

There is no pending update, at least I have done all required updates and permanently inquiring for software updates hoping there would be one fix out there. I did not drop the phone down and the SIM are new as I had to move to nano while migrating to M4.
Emperor
Message 5 of 20
3,373 Views
Message 5 of 20

Re: SIM1 gets disable - please help

@Trialbyfire

 

You could contact your Local support to get the phone inspected.




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Regular
Message 6 of 20
3,338 Views
Message 6 of 20

Re: SIM1 gets disable - please help

Well, I swapped the Sim cards between each other in the slots. It has been 2 days since after having several factory resets and looks promising and stable so far. While the Sim disable issue might be fixed I started facing another one with Wi-Fi connection which cannot be enabled unless the phone is restarted. It is a full of bugs phone, I do not think I will ever buy a Sony smartphone again. Sorry, no time for local support.
Regular
Message 7 of 20
3,324 Views
Message 7 of 20

Re: SIM1 gets disable - please help

It seems SIM1 disable problem is still there, it started again today. Now I know it is not the SIM card but the phone, either the slot or Android bug. Anyway as no one experienced this problem I do not expect any solution coming from this forum but having the phone inspected. One thing is clear Sony is a big disappointmen!
Emperor
Message 8 of 20
3,314 Views
Message 8 of 20

Re: SIM1 gets disable - please help

@Trialbyfire

 

Contact your Local support to get it inspected. 




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

One time poster
Message 9 of 20
3,287 Views
Message 9 of 20

Re: SIM1 gets disable - please help

Hi!

 

I am facing the same problem here on M4 Aqua. SIM1 which has a new nano sim gets disabled automatically and I have to restart the phone to get it working. Today it happened while I was on a call and this is absolutely frustrating. I am not sure if this has to do with another SIM lying in SIM2, which is disabled by default. Since its a roaming SIM (SIM2), I only enable it on need basis.

 

Any ideas / thoughts what could be done?

 

Regards,

Anand.

Regular
Message 10 of 20
3,279 Views
Message 10 of 20

Re: SIM1 gets disable - please help

I swapped the Sim cards and it was the same. After being OK for a couple of days, the problem came back. And it did not come alone Wi-Fi and Bluetooth connections were going off. Unless restarting they would not get enable again. Then 2 days ago the phone restarted by itself while playing a video and connected to Wi-Fi. It lasted several minutes to restart. Yesterday ant today was stable. I do not know if it is a hardware or software problem. Try to reset it to factory settings, make sure you remove any call forward settings to avoid any artificial costs with roaming and since Sim 2 is remaining move the one you frequently use in slot 2. Last we should probably make an official complaint to Sony.