account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Want to know more about Xperia 5? To read more about it go here.
If you can't find the answer to your question there please post it here and let the community help you.

M4 Ram issue, shows only 883 MB...

SOLVED
Apprentice
Message 21 of 140
3,672 Views
Message 21 of 140

Re: M4 Ram issue, shows only 883 MB...

My solution was fast.. I bought a brand new sony m5. The m4 has Stilo the same issue... Not sure if the android 6.0.1 is optimized to that Phone... Sony leaves same models behind without support... :/
Highlighted
Apprentice
Message 22 of 140
3,663 Views
Message 22 of 140

Re: M4 Ram issue, shows only 883 MB...

Sorry @Damil, but I don´t think that´s a reasonable solution. I had this M4 for 9 months and I don´t think that buy another Sony Smartphone is the best way without any official position of them about this issue. Actually if so, this is the last thing I´m gonna do. I could even buy another Smartphone, but not a Sony one. I still want a answer, where are my 2 gb RAM memory?

Genius
Message 23 of 140
3,651 Views
Message 23 of 140

Re: M4 Ram issue, shows only 883 MB...

Hi @AraujodeSouza,

 

I'd like to collect a bug report from you regarding this.

 

To do this:

Go to Settings > About phone > Build number, tap 7 times on the build number.
Go back and select Developer options then turn on "USB debugging".
Select Logger buffer size and change it to "4 M"
Restart your phone, then replicate the issue
Go back to Settings > Developer options, select "Take bug report".

When the report is ready you will receive a notification. Tap the notification to share it. I suggest you upload it to Google Drive and then send choose to share a public link to the upload and include the link in the PM. I'd also like you to include the IMEI number for your phone in the PM, dial *#06# to find out your device's IMEI.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Adviser
Message 24 of 140
3,645 Views
Message 24 of 140

Re: M4 Ram issue, shows only 883 MB...

Hello Didrik,

Would you mind if i did a bug report too? i am having the exact same issue.

However i'm not sure what you mean by "Restart your phone, then replicate the issue" since the issue is that android reports the wrong RAM (883Mb total instead of something closer to 2GB)..

Thank you for the feedback.

 

Genius
Message 25 of 140
3,629 Views
Message 25 of 140

Re: M4 Ram issue, shows only 883 MB...

Hi @BH06,

 

That'd be much appreciated. 

 

By "replicate the issue" I mean, perform the necessary steps to show that there is only 1 GB RAM showing. So after the reboot, go to Settings and open up the menu displaying the total amount of RAM in your phone > Then collect the bug report.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Learner
Message 26 of 140
3,561 Views
Message 26 of 140

Re: M4 Ram issue, shows only 883 MB...

Hi, I've had the same problem. After charging my device, proceeded to turn at first did not respond after a few minutes came a blue screen, and constantly reboot. Accomplish off and start but was too slow check using the device memory and recognized it as a total RAM 883 Mb and any moment appeared blue screen and reboot constantly. I've completed the steps in the application Xperia companition but without any result the phone was restored but the problem persists.
Genius
Message 27 of 140
3,530 Views
Message 27 of 140

Re: M4 Ram issue, shows only 883 MB...

Hi @RobertPorto,

 

Do you mean that you performed a software repair in Xperia Companion and that the phone is still rebooting after the blue screen appears? What steps do you have to take in order for this blue screen to appear or is it directly at startup?

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Learner
Message 28 of 140
3,519 Views
Message 28 of 140

Re: M4 Ram issue, shows only 883 MB...

There are occasions in which when starting out the blue screen after XPERIA logo lasts 3 seconds and restarts, preciono the power button again and there are times in which the screen or normal start. When you start without blue screen, I check with the diagnostic application and the device shows only 883 MB RAM memory, and the device is too slow.

Genius
Message 29 of 140
3,496 Views
Message 29 of 140

Re: M4 Ram issue, shows only 883 MB...

@RobertPorto, could you try booting your phone without your SIM- and SD-card (if you have an SD-card) inserted. Does the blue screen still appear and the reboots still happen?

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Adviser
Message 30 of 140
3,330 Views
Message 30 of 140

Re: M4 Ram issue, shows only 883 MB...

To those with this problem... there is a new update for you to install.

I have the 2Gb back after installing it.. and so far no blue screen.. i'm keeping my finger's cross for this firmware version!!!

I hope it will solve the problem for all of you!

Best,

BH06