account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

M2 Aqua problem with updating to lollipop 5.1.1.

SOLVED
Visitor
Message 1 of 7
2,121 Views
Message 1 of 7

M2 Aqua problem with updating to lollipop 5.1.1.

Hello.

Today I tryed updating my phone to lollipop 5.1.1. , but something went wrong and now i can't even start my phone. When i go to Sony PC Companion I tryed to go to support zone and repair the device, but i had no luck. It is always saying that i have no internet connection, but i do. I deactivated the firewall and my anti virus, tryed again and the same thing happend. What should i do? Please help?

1 ACCEPTED SOLUTION

Accepted Solutions
Genius
Message 4 of 7
2,894 Views
Message 4 of 7

Re: M2 Aqua problem with updating to lollipop 5.1.1.

Hi @Stojko

 

Press the 3 buttons Power, Volume down and Volume up for about 8-10 seconds and then release them, check if the Sony logo appears. Also try booting into Flashmode as explained here. I´m at disposal for any question.

"We can have anything we want on life, if we just help others to found what they need” - Ebelsain Villegas
6 REPLIES 6
Genius
Message 2 of 7
2,111 Views
Message 2 of 7

Re: M2 Aqua problem with updating to lollipop 5.1.1.

Hi @Stojko

 

You can try to install Lollipop using Flashtool as explained here. I´m at disposal for any question.

"We can have anything we want on life, if we just help others to found what they need” - Ebelsain Villegas
Visitor
Message 3 of 7
2,100 Views
Message 3 of 7

Re: M2 Aqua problem with updating to lollipop 5.1.1.

Hi @xavinux

It says here that i need to enable usb debugging, but i can't power up my phone. Is there another way?

Genius
Message 4 of 7
2,895 Views
Message 4 of 7

Re: M2 Aqua problem with updating to lollipop 5.1.1.

Hi @Stojko

 

Press the 3 buttons Power, Volume down and Volume up for about 8-10 seconds and then release them, check if the Sony logo appears. Also try booting into Flashmode as explained here. I´m at disposal for any question.

"We can have anything we want on life, if we just help others to found what they need” - Ebelsain Villegas
One time poster
Message 5 of 7
1,812 Views
Message 5 of 7

Re: M2 Aqua problem with updating to lollipop 5.1.1.

i have the same problem, i have the sony logo appearing ater pressing the power and volume up but after that lightly black screen appears and no more.please help, some solutions.thanks

Highlighted
Genius
Message 6 of 7
1,695 Views
Message 6 of 7

Re: M2 Aqua problem with updating to lollipop 5.1.1.

Hi @zeddlambert

 

You can also try installing Lollipop using XperiFirm and Flashtool as explained in the following link:

http://www.xperiablog.net/2015/03/17/guide-to-installing-xperia-lollipop-using-xperifirm-and-flashto...

 

Note: In the last version of Flashtool XperiFirm has been included.

"We can have anything we want on life, if we just help others to found what they need” - Ebelsain Villegas
Talent
Message 7 of 7
1,665 Views
Message 7 of 7

Re: M2 Aqua problem with updating to lollipop 5.1.1.

Re flash ftf and wipe cache and data