account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests with the support app directly on your phone.
Read more and discuss the app here.

Xperia M not working through USB cable at all

One time poster
Message 1 of 1
Message 1 of 1

Xperia M not working through USB cable at all

I have a Xperia M C1904. I have been attempting to connect it to my laptop for the passst week, with no success. I have tried the Xperia Companion, have tried USB debugging mode, tried different cables, etc.


The laptop will not even acknowledge that a device is plugged in, no Windown sound detecting a new USB device, not under Linux with a device list, nothing.


I'm running Windows 7 and Linux Mint dual-boot and have tried both OSes.


I'm looking to flash a new rom to this old phone via ADB / FastBoot and seem to have to use ADB first to install TWRP.


If there's an alternative way to install a rom without a USB cable, I'd love to hear it.


I'm about to try to build a bootable SD card to see if that can finally boot TWRP to flash this thing.


I know the USB port itself is perfectly good, it'll read a USB thumb drive on a USB OTG cable. That tells me the port itself is not bad with a busted data pin or something.


I'm hoping others outthere have had this problem before and know the solution.