account arrowhead-down arrowhead-up cart mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Mobile World Congress 2019

Sonys Press conference from MWC took place end of February
If you missed it you can watch it here.
Please join the discussion here and share your thoughts on what was anounced here. MWC 2019 discussion.

Xperia C4 Dual - Rebooting when connected to charger

Apprentice
Message 31 of 40
1,456 Views
Message 31 of 40

Re: Xperia C4 Dual - Rebooting when connected to charger

Just having the same issue today after using a portable insignia charger, it said 80% and when I checked it again at work was down to 15%! I already did the phone repair option with xperia companion but the problem persists. Also when I connect it it to charge it instantly turns off and begins to reboot over and over again in a loop. Hopefully there is an update soon and it fixes the issue. I am going to try a full reset and if the problem persists I am upgrading to the Z5. Really a shame, I like this phone alot. Guess nothing good lasts forever, perhaps the battery is finally damaged from so much use.

 

If anyone has found a way to fix, please share!

One time poster
Message 32 of 40
1,399 Views
Message 32 of 40

Re: Xperia C4 Dual - Rebooting when connected to charger

same problem here. 

been like this since 2 the last two month. but my warranty just out. been using this phone a year. 

any suggestion beside replacing with other phone. i really like this phone.

 

thank you

One time poster
Message 33 of 40
1,369 Views
Message 33 of 40

Re: Xperia C4 Dual - Rebooting when connected to charger

Have the same problem here..really annoying...anyone have solutions?

One time poster
Message 34 of 40
1,305 Views
Message 34 of 40

Re: Xperia C4 Dual - Rebooting when connected to charger

You know i started having this exact same issue about two weeks ago. Tried several different things I had read online, including a factory reset, but nothing worked. Just today i started looking into the installed apps on my phone and i came across a curious one called autopoweroffservice. I disabled it and voila!! My phone started charging without rebooting every 10 seconds.
One time poster
Message 35 of 40
1,225 Views
Message 35 of 40

Re: Xperia C4 Dual - Rebooting when connected to charger

THANKS A MILLION TIMES!. I found the solution,  hit at the back of your phone with your fingers and it will charge. The problem is just a LOSE CONNECTION.

Learner
Message 36 of 40
1,210 Views
Message 36 of 40

Re: Xperia C4 Dual - Rebooting when connected to charger

i am faceing the same problem now any solutions 

Learner
Message 37 of 40
1,091 Views
Message 37 of 40

Re: Xperia C4 Dual - Rebooting when connected to charger

me too i have the same problem with my sony c4 dual 

any help ??

Visitor
Message 38 of 40
672 Views
Message 38 of 40

Re: Xperia C4 Dual - Rebooting when connected to charger

I have the same problem i send it to service center then they fixed. After 7 months it’s happening again, the fact about sony c4? This phone is trash! Touch screen having problem, rebooting, all defects that you will see in an android its here in this phone. Disappointing. 

One time poster
Message 39 of 40
600 Views
Message 39 of 40

Re: Xperia C4 Dual - Rebooting when connected to charger

open back cover ur sony C4 dual.. put ur battrey... "banting dengan cara mentatar sebanyak 5 kali"  I mean... u can used indonesian language..... u can solved ur problem  Slightly smiling Face

One time poster
Message 40 of 40
326 Views
Message 40 of 40

Re: Xperia C4 Dual - Rebooting when connected to charger

Thank you for your suggestion. I disabled the autipoweroffservice. Now it's working fine.