account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Want to know more about Xperia 5? To read more about it go here.
If you can't find the answer to your question there please post it here and let the community help you.

Xperia 1 Bluetooth call issues

SOLVED
Apprentice
Message 1 of 7
1,720 Views
Message 1 of 7

Xperia 1 Bluetooth call issues

Hi All,

 

Found a bit of a bug (maybe?) with my new Xperia 1 today.

 

I have connected it to the Bluetooth on my car (Audi MMI) and a pair of Sony Headphones I have.

 

Works absolutely fine with audio, but when making a call, it always goes through the handset.

 

I've been into the settings and both devices are ticked for call audio through Bluetooth. When I am on the call, I can select handset/speaker/MDR-XB650-BT (my wirelessheadphones). However, I can't actually select the headphones. When I click on it, it just reverts to highlighting the handset. The same happens in my car.

 

It appears to recognise them both, and audio works, but not currently working for making calls!

 

I've just upgraded from an Xperia XZ Premium and that worked fine with both.

 

Does anyone have any advice / has anyone had to over come the same thing?  

 

Thanks in advance!

 

_20190628_155843.JPG

 

1 ACCEPTED SOLUTION

Accepted Solutions
Message 3 of 7
1,633 Views
Message 3 of 7

Re: Xperia 1 Bluetooth call issues

For your headset, go in to Settings - Device Connection  - Previously connected devices, click the cogwheel on the headset, and make sure it has call audio, media audio, and contact sharing enabled.

 

Failing that, go into Settings - Apps and notifications, tap the 3 vertical dots on the top right of the screen, pick "show system", and select Bluetooth, from the app list.

Then go into Storage, and clear cache, and data, and restart the phone.

That step can also help to fix issues with the car connection.

 

This will cause you to re-pair with the previous items, but don't forget to "forget" any connections you have made on previous kit, like the car, go into connections and forget the phone, before you try Bluetooth again.

 

For Bluetooth issues in the car, you may have to pick another Bluetooth version, and for that, it's Settings - System - About phone, scroll down to Build number, and keep tapping till it tells you are a developer.

Then it's Settings - System - Advanced, and select Developer options, scroll down to "Bluetooth AVRCP" and change it from 1.6 to one of the other settings, that might cure your issues also.

6 REPLIES 6
Adviser
Message 2 of 7
1,639 Views
Message 2 of 7

Re: Xperia 1 Bluetooth call issues

I have exactly the same problem with a Sony bluetooth car stereo.

 

Audio via USB doesn't seem to work either, locks the phone into a loop of it asking for an access permission until the USB is removed.

Message 3 of 7
1,634 Views
Message 3 of 7

Re: Xperia 1 Bluetooth call issues

For your headset, go in to Settings - Device Connection  - Previously connected devices, click the cogwheel on the headset, and make sure it has call audio, media audio, and contact sharing enabled.

 

Failing that, go into Settings - Apps and notifications, tap the 3 vertical dots on the top right of the screen, pick "show system", and select Bluetooth, from the app list.

Then go into Storage, and clear cache, and data, and restart the phone.

That step can also help to fix issues with the car connection.

 

This will cause you to re-pair with the previous items, but don't forget to "forget" any connections you have made on previous kit, like the car, go into connections and forget the phone, before you try Bluetooth again.

 

For Bluetooth issues in the car, you may have to pick another Bluetooth version, and for that, it's Settings - System - About phone, scroll down to Build number, and keep tapping till it tells you are a developer.

Then it's Settings - System - Advanced, and select Developer options, scroll down to "Bluetooth AVRCP" and change it from 1.6 to one of the other settings, that might cure your issues also.

Apprentice
Message 4 of 7
1,531 Views
Message 4 of 7

Re: Xperia 1 Bluetooth call issues

Clearing the cache and restarting worked for both of my cars and headphones, haven't had any problems since! Thanks!

One time poster
Message 5 of 7
1,432 Views
Message 5 of 7

Re: Xperia 1 Bluetooth call issues

Hi, Mattbs3

Plz restart ur phone to solve this issue. Mine has been solved when I restart my xperia 1 connecting with wf-1000xm3.

 

Kind Regards

 

Highlighted
Adviser
Message 6 of 7
931 Views
Message 6 of 7

Re: Xperia 1 Bluetooth call issues

Going to down to version 1.5 from 1.6 did the trick for me. MZD Connect car entertainment in Mazda3 2014.

Thanks! 

Visitor
Message 7 of 7
725 Views
Message 7 of 7

Re: Xperia 1 Bluetooth call issues

The version of Bluetooth on my phone?