account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

LDAC is not working properly on Xperia 1

SOLVED
Learner
Message 1 of 14
972 Views
Message 1 of 14

LDAC is not working properly on Xperia 1

first of all, I love Sony phones. Unfortunately I have reservations about the new Flagship the Xperia 1. Before I was using an Xperia XZ Premium. That phone is the greatest and I'm even thinking of switching back. Why? I like the userinterface better, the bluetooth connection with LDAC enabled Sony Headphones works a whole lot better and the overall stability is so much better. 

Is there anyone out there that has a solution. I really want to use the LDAC functionality. It makes quite a difference in sound. I sincerely hope that Sony can fix the problems by updating software soon. It is starting to get annoying.

#MDR-1ABT 

#MH-1000xm3

 

1 ACCEPTED SOLUTION

Accepted Solutions
Learner
Message 14 of 14
959 Views
Message 14 of 14

Re: LDAC is not working properly on Xperia 1

Only had one hickup, but bad WiFi is more suspect to that. Closing this issue. 

View solution in original post

13 REPLIES 13
Message 2 of 14
958 Views
Message 2 of 14

Re: LDAC is not working properly on Xperia 1

It does support and utilise LDAC compatible equipment, and does it really well.

It also auto picks the setting it detects best, but you can change it.

 

If you are having issues, you can either see if the headphones/earphones, can use the Headphones App, which you can download from the Play Store, or failing that, go into Settings - Sound - Quality - Audio Settings - and enter the Accessory Settings.

From the Sound settings you can enable Dolby Atmos, which for music is really nice, Dynamic being particularly smart at its job, among other settings.

 

Or if you are still unhappy, simply unlock the developer options(shouldn;t be too hard to figure out or find), and scroll down to Networking where you can change the Bluetooth version, or indeed force it to use basic LDAC in the Bluetooth Audio Codec section, if your headphones, don't support newer codecs, and finally there are a few other settings there like LDAC playback quality.

 

Learner
Message 3 of 14
938 Views
Message 3 of 14

Re: LDAC is not working properly on Xperia 1

Thank you RottenFoxBreath, I will have a go at it. As I am a lazy person, I would expect a flagship phone to work flawlessly with same brand top of the range head phones. (especially if they give away one of them with the phone... )

I will get back on this.

Message 4 of 14
933 Views
Message 4 of 14

Re: LDAC is not working properly on Xperia 1

Wait, so it's the WH ones you have..the over head ones that they gave away free for the offers with the phone.?

If so, check for a software update for them, then calibrate them in the Headphones app..

Learner
Message 5 of 14
922 Views
Message 5 of 14

Re: LDAC is not working properly on Xperia 1

indeed it is the WH-1000xm3. But also the Sony MDR-1ABT. Both of them work perfectly on my old XZ Premium with LDAC engaged. Sadly the sound is sometimes garbled on the xperia 1

Talent
Message 6 of 14
913 Views
Message 6 of 14

Re: LDAC is not working properly on Xperia 1

I heard of this issue before, but there was no fix to it

 

Though not help directly, I do appreciate the issue.

 

I play FLAC files and as such no matter what Sony says or how good it is, LDAC will never be as good as wired headphones when playing up to 96KHZ 24 bit FLAC files.

 

To get around the wired issue, i dont bother with Sony's internal DAC for playing music, i actually purchase a USB C to A OTG cable and then purchase an Audiogalaxy Dragon FLY external dac (the size of a USB flash drive) then plug WIRED headphones at the other side of that.

 

Paired with USB audio player you get better sound and seperation of instruments than any internal dac can do wired or not.

 

Back to your LDAC issue. Did you try Fox's excellent solution?

Message 7 of 14
911 Views
Message 7 of 14

Re: LDAC is not working properly on Xperia 1

I've personally got one of these Odyssey HD Usb C mobile DAC dongles, and it works beautifully.

as GilgameshUK says, these far and away beat the pants off wireless, aiding wired IEM's/headphones to sound so much better.

And works very well with the Offer headphones from Sony, the WH-1000AM3s', and a snip at around a tenner delivered(e-packet delivery).

The owner of VE audio, Lee, is probably one of the coolest people I know, and knows his stuff.

Highlighted
Talent
Message 8 of 14
901 Views
Message 8 of 14

Re: LDAC is not working properly on Xperia 1


@RottenFoxBreath wrote:

I've personally got one of these Odyssey HD Usb C mobile DAC dongles, and it works beautifully.

as GilgameshUK says, these far and away beat the pants off wireless, aiding wired IEM's/headphones to sound so much better.

And works very well with the Offer headphones from Sony, the WH-1000AM3s', and a snip at around a tenner delivered(e-packet delivery).

The owner of VE audio, Lee, is probably one of the coolest people I know, and knows his stuff.


Hey bud do those offer headphones also support wired? Personally i would not touch wireless not matter how good they say they are: iF they can do wired and wireless it might be an option for a future time.

Learner
Message 9 of 14
899 Views
Message 9 of 14

Re: LDAC is not working properly on Xperia 1

It does support wired, but the Xperia 1 had no jack. It can connect through a USB-c dongle. A bit of a hassle. 

 

I found something interesting on another forum that I am currently trying. Remove the Sony Music Center app. Thusfar, the sound has been uninterrupted. Will report back after a day or two. I have no idea why this would work, but I'm ready to try. 

Talent
Message 10 of 14
897 Views
Message 10 of 14

Re: LDAC is not working properly on Xperia 1

Yes i know about the usb c dongle budSlightly smiling Face

Was just saying if the headphones suypport wired also, then simply plug them into my external USB dac then that into the OTG cable and then into the phone.

No headphone jack isnt a problem for me as like i said an external USB DAC brings back the headphone jack.

https://www.whathifi.com/audioquest/dragonfly-black-v15/review