account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Issue with network dropping

Talent
Message 81 of 150
439 Views
Message 81 of 150

Re: Issue with network dropping

This probably does not help, but I have an XZ2, & all the time I am at home I only have 1 bar on 4G, but still the phone is most of the time lightening fast, when surfing the web, watching YouTube etc. 

Enthusiast
Message 82 of 150
431 Views
Message 82 of 150

Re: Issue with network dropping


@drlmiles wrote:

@Chippy_boy wrote:

@Emil93 wrote:

😂ok if you say the signal bars means nothing...I have 2 signal bars on my S10 + and no signal on Expedia 1 on the same network same location..🥺


And as I say, that means nothing.  Maybe the signal is worse on the XP1, but maybe it is actually better. You cannot tell from the signal bars because manufacturers calibrate them completely differently.

 

Quote from XDA Developers:

 

"The bars mean nothing. Sony phones take into consideration RSRQ(signal quality) and SINR(s noise) values of the signal. Other oem don't. The actual signal power RSRP (do not confuse it with bars) is same or better on Sony.
Xperia 1 has most advanced modem and antenna setup of any 4g phone. 4x4 mimo even on low bands (first to have it)."


@chippy_boy Thanks for this.

No-one should be returning their X1 because of the reported bars on the status bar on the phone.


Absolutely correct. I've just tried an app called netmonster - quite a neat app actually - which shows you in great detail the connection you have, signal strength and quality etc. And also which mast you're connected to and where the nearest ones are on your network.

 

Checking my XP1 and my wife's Pixel XL 2, side by side, both on Vodafone my XP1 actually has slightly better signal strength.  Although strangely, the signal to noise ratio seems much worse.

Talent
Message 83 of 150
419 Views
Message 83 of 150

Re: Issue with network dropping

Just installed netmonster after your recommendation. Doesn't make much sense to me. Do you need to have it running in the background? What info on the app should I be looking at regarding my signal quality? 

Highlighted
Talent
Message 84 of 150
411 Views
Message 84 of 150

Re: Issue with network dropping

Is there anyone NOT with EE but having this issue?

Adept
Message 85 of 150
408 Views
Message 85 of 150

Re: Issue with network dropping

I haven't seen anyone not using EE and having issue yet. it seems we all on EE. (supposed the be the best network in UK)

Sage
Message 86 of 150
398 Views
Message 86 of 150

Re: Issue with network dropping


@harunt wrote:

I haven't seen anyone not using EE and having issue yet. it seems we all on EE. (supposed the be the best network in UK)


Someone on here in Norway also had the same problem - not on EE

Learner
Message 87 of 150
384 Views
Message 87 of 150

Re: Issue with network dropping

I'm not a EE customer. I got my Xperia 1 from Telia in sweden, and as I posted earlier I also had this problem.

 

My modell is J9110. I installed the .278 update yesterday and so far I have not had any more issues which is a great relief.

Adept
Message 88 of 150
382 Views
Message 88 of 150

Re: Issue with network dropping

Hi thanks for that, seems most of us still waiting for this update, but at least it seems the update will fix it

Enthusiast
Message 89 of 150
365 Views
Message 89 of 150

Re: Issue with network dropping


@JanieD91 wrote:

Hi thanks for that, seems most of us still waiting for this update, but at least it seems the update will fix it


I'm not holding my breath to be honest.  A guy in Sweden on another network could have been experiencing a similar (or different) problem with a different resolution. Maybe there was a network issue in Sweden which is now resolved.  Or something else altogether.

 

Unfortunately here in the UK it seems only those EE customers who bought from EE direct, have had the update. And those customers weren't having problems in the first place.  So until someone like you or me gets the new update, the jury is out on whether this will fix it.

Adviser
Message 90 of 150
356 Views
Message 90 of 150

Re: Issue with network dropping

I am finding it annoying that some members keep stating signal bars don't mean anything. That is untrue because if they mean nothing why have them? I bought 2 Xperia 1 devices from 2 separate retailers and tried my EE SIM card in both and at home where I always have full bars and have never had signal problems on any other phone but with both Xperia 1 phones the 4g signal will be at 4 bar's then drop to 2 bars then 1 bar then lose connection completely and then after 30 seconds it reconnects and goes to 4 bar's then repeats this cycle every few minutes. I have tried another EE SIM card I have and same problem, I have reset network settings, manually entered the EE data settings, reset both device's and the problem continues. Using the same Sims in the same location at the same time in Samsung, iPhone, pixel, Huawei, OnePlus, Honor Device I have full reception and it doesn't drop and my signal does not disconnect at all. I have tested a theory and spoken to both EE and Sony and I can tell you this, if you use a non EE branded Xperia 1 on EE then you will suffer from this problem. EE by default use volte for phone calls which they can't switch off, but using a vanilla Xperia 1 it doesn't have the software to use 4g to make calls volte. My Xperia 1 instead makes calls over 3g or 2g which is means it disconnects from 4g and also means that the phone can't utilize the full bands and coverage EE provide. Sony needs to add the correct software to handle the EE network for the problem to be resolved. If you bought the Xperia 1 direct from EE then you will have zero issues because EE have the correct software on their own devices. This is not a hardware fault, it has nothing to do with bars showing the incorrect reception level. My friend has bought an Xperia 1 from carphone warehouse and received the update, carphone warehouse phones are carphone warehouse branded ROMs not factory even though they are unlocked. I'm guessing Sony pushed out the update to carphone warehouse and EE branded devices because they have bought a lot of handsets from Sony and were getting people complaining about the handsets not working properly. For some reason Sony don't care about those of us who bought factory unlocked devices. The advice Sony tech support gave me was to return both handsets and when I asked if they would be releasing an update to resolve the problems they refused to answer the question and totally ignored it several times even when I pushed them about it. They said they only way to resolve the issue was for me to return both handsets to the retailers I bought them from. I also have the transcript if anyone doubts me. Personally I find it ridiculous that Sony have advised me to return both handsets as the solution to the problem and no explanation of why this is happening! I hope this helps everyone with the same problem I am having.