account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Camera issue

Regular
Message 1 of 11
569 Views
Message 1 of 11

Camera issue

My camera key on the Xperia 1 is working properly but the camera app doesn't recognize it. On the rare occasion the camera app will recognize it and will take a picture, but if I go into settings or leave the app and go back into the app it will stop working again.

 

Also it seems like there is a big lag on saving the pictures even if it's on my phone storage, and the stock photo app is really slow at moving and deleting pictures.

 

On another note if I get sms messeges for Samsung phones rear camera it shows up as black and white

10 REPLIES 10
Enthusiast
Message 2 of 11
561 Views
Message 2 of 11

Re: Camera issue

Make sure everything is updated. Restart the device in safe mode to make sure no third party apps are causing issues. There is processing of the image before saving which does take a couple seconds, but deleting has been very quick for myself.

I have been having weird issues with Messages myself. I have received BW photos from Moto phones randomly and also not being able to receive gifs but can send them.

Regular
Message 3 of 11
556 Views
Message 3 of 11

Re: Camera issue

Safe mode didn't work for me and everything is updated 

Enthusiast
Message 4 of 11
553 Views
Message 4 of 11

Re: Camera issue

Worse case is FDR.

Regular
Message 5 of 11
505 Views
Message 5 of 11

Re: Camera issue

I've done a factory reset as well and still same problem 

Sony Xperia Support
Message 6 of 11
459 Views
Message 6 of 11

Re: Camera issue

Hi @Kc718, let me see if I can help out here!

 

Have you been able to carry out a quick test of the camera key in the support app to see if the hardware (the key itself) is responding as intended. Find and tap Settings > Support > Xperia Tests > Camera key. Also, try clearing the data for the camera app. This will reset all settings for the camera app which might do the trick. Find and tap Settings > Apps & notifications > Show all XX apps > Camera > Storage > Clear data > Tap "OK" > Restart the phone.

 

If the camera key still misbehaves after this, I would suggest that you try a software repair using Xperia Companion and a computer. do note that a software repair will erase all user data from the phone, so it is advised to do a backup before the repair to avoid data loss.

 

Try this and let me know how it goes! 


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

Regular
Message 7 of 11
439 Views
Message 7 of 11

Re: Camera issue

Just tried everything you advised and its still not working.

Sony Xperia Support
Message 8 of 11
382 Views
Message 8 of 11

Re: Camera issue

Thank you @Kc718 for the quick reply.

 

I believe that the best thing to do in your situation is to have the phone physically examined and repaired. In that case, please get in contact with your local support team, they should be able to arrange for the phone to be sent to an authorized service center as well as answer questions regarding local warranty and consumer laws.

 

Feel free to keep me posted with how it goes! 


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

Regular
Message 9 of 11
351 Views
Message 9 of 11

Re: Camera issue

The thing is the button fully works with other apps like Snapchat and the Cinema pro app and it even open up my camera app no problem. The only thing it doesn't do is take pictures but on the rare occasion it will snap pictures.

 

The hardware is fully functioning, it's the software that isn't functioning correctly. I feel like the camera app itselft is very buggy (slowly opens sometimes, slow to take pictures). 

 

Seems like this phone was rushed and hopefully Sony will fix it. So far it doesn't look like they are putting much effort into their phones UI.

Sony Xperia Support
Message 10 of 11
348 Views
Message 10 of 11

Re: Camera issue

Hi again @Kc718,

 

I am afraid that I have to disagree with you on that point. If this was related to the software, the behaviour you speak of would be fixed by a software repair. However since the behaviour persists even though you performed the software repair, the only thing left to do is to have the phone physically examined by an authorized service center.

 

Let me know if you have any further questions! 

 


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.