account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

XZ Premium cannot reconnect to WiFi after Oreo

Highlighted
Enthusiast
Message 1 of 136
7,052 Views
Message 1 of 136

XZ Premium cannot reconnect to WiFi after Oreo

Hi there!

 

After update to Oreo my XZ Premium (and my XZ1 Compact) sometimes (but not always) cannot reconnect to saved WiFi networks. Even if I go to WiFi settings and force it to connect via menu it still cannot connect. It connects smoothly after restart. Very annoying. 

 

Another interesting bug is that sometimes it takes my phone quite a while to open address book. Restart cures this one too. 

 

Any idea?

135 REPLIES 135
Highlighted
Sony Xperia Support
Message 2 of 136
7,038 Views
Message 2 of 136

Re: XZ Premium cannot reconnect to WiFi after Oreo

Hi @RussianOne, I am sorry to hear about this Slightly frowning Face 

 

Do you experience the same issue in safe mode?


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

Highlighted
Enthusiast
Message 3 of 136
7,032 Views
Message 3 of 136

Re: XZ Premium cannot reconnect to WiFi after Oreo

I actually never tried because I cannot afford running the phone in safe mode for a day or two. I understand it may be caused by third-party apps, however. 

 

The very fact that it started with Oreo update in XZ Premium and it was the case with XZ1 Compact out of the box tells me there is something wrong with the OS. 

 

Am I the only one having this issue? 

Highlighted
Moderator
Message 4 of 136
7,028 Views
Message 4 of 136

Re: XZ Premium cannot reconnect to WiFi after Oreo

@RussianOne

My WiFi works perfectly, I own a Single SIM XZP. Do you have the Single or Dual SIM variant?



Feel free to kudo this post or mark it as solution so that other users facing the same issue can find it

Disclaimer: Moderators are not affiliated with or work for Sony Mobile, their posts represent their own opinions and views. Click here to find out more about the different roles in the community.

Highlighted
Enthusiast
Message 5 of 136
7,025 Views
Message 5 of 136

Re: XZ Premium cannot reconnect to WiFi after Oreo

Dual Sim

Highlighted
Visitor
Message 6 of 136
6,958 Views
Message 6 of 136

Re: XZ Premium cannot reconnect to WiFi after Oreo

I see the WiFi issue too. Dual SIM. Toggling WiFi on and off fixes it. Very annoying.

Highlighted
Inhabitant
Message 7 of 136
6,943 Views
Message 7 of 136

Re: XZ Premium cannot reconnect to WiFi after Oreo

Having the problem too, tried everything, safe mode, network reset, deleting and recreating wifi connection. Every few hours wifi simply breaks, wont reconnect (and yes wifi is fine... 

Highlighted
Inhabitant
Message 8 of 136
6,942 Views
Message 8 of 136

Re: XZ Premium cannot reconnect to WiFi after Oreo

Only thing that fixes it is a reboot and then its fine but after a few hours same thing over and over. This is a bug, note Oreo on Google Pixel phones caused the same problem, just google it... Can someone in Sony please admit there is a bug and sort please ASAP

Highlighted
Inhabitant
Message 9 of 136
6,967 Views
Message 9 of 136

Wifi Issues Oreo / Xperia-XZ-Premium

Would anyone with problems with their wifi connection constantly dropping please post here. Since Oreo updated having endless cases of wifi disconnecting and need to reboot phone to reconnect. All obvious stuff tried and Sony support no help just suggesting basic fixes none of which work. Oreo wifi problems seem to be bugging Pixel phones too but why on earth did Sony release 8 if it is so buggy?? And not test it properly???? 

 

Please post here if you are having problems!! 

Highlighted
One time poster
Message 10 of 136
6,961 Views
Message 10 of 136

Re: Wifi Issues Oreo / Xperia-XZ-Premium

Same for me, need to reboot every time to connect again