account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

XZ Premium cannot reconnect to WiFi after Oreo

Highlighted
Talent
Message 11 of 136
2,544 Views
Message 11 of 136

Re: Wifi Issues Oreo / Xperia-XZ-Premium

I've read an article saying it's Android 8.0 issue with WEP.

 

Even if you are NOT connecting your router with WEP, Wifi disconnectivity issue can happen as long as the rounter is set to be compatiable with WEP.

 

So the only way to resolve the issue is to disable WEP on the router, or choose WPA/WPA2 only.

 

Try this, and hope this works.

Highlighted
Inhabitant
Message 12 of 136
2,529 Views
Message 12 of 136

Re: Wifi Issues Oreo / Xperia-XZ-Premium

Thanks Jotaro identical problem. 

Highlighted
Inhabitant
Message 13 of 136
2,527 Views
Message 13 of 136

Re: Wifi Issues Oreo / Xperia-XZ-Premium

Ok thanks but work network and so many networks use wep its not practical to get them to change just because Sony/Google cant fix a simple software glitch.

 

Can someone in Sony explain that they are working on this please???? 

Highlighted
Message 14 of 136
2,514 Views
Message 14 of 136

Re: Wifi Issues Oreo / Xperia-XZ-Premium

I find it hard to believe that any reputable company WiFi is still using WEP for security. I work in IT and WEP is the least secure of them all...easily cracked. So if they are using WEP then they need to get with the program already. Why should any software company make their WiFi code compatible with something that was replaced long ago with encryption that is many, many times better? Just check your home router and make sure you are not using WEP. Then see if it helps.

Highlighted
Inhabitant
Message 15 of 136
2,508 Views
Message 15 of 136

Re: Wifi Issues Oreo / Xperia-XZ-Premium

What a ridiculous post, from experience many wifi networks from coffee shops to home networks to some business networks for visitor wifi still use WEP, I know it can be hacked but that is not the point. It is a wifi standard still in use. Jo Punter who just wants to hop onto a wifi network doesnt care about the security protocol used. If Sony update software that means it wont work with many wifi networks just because some techie thinks one form of encryption is obsolete then we should be told in advance. The reality is if I follow your logic is that you think its perfectly ok for Sony to release a top end phone which cant use many wifi networks. Not sensible or acceptable. Will do some further testing over the weekend to see can I confirm that this is a WEP only bug. Would be lovely if someone from Sony actually did their job and didnt leave it to a random customer to try and figure out why their handset wont work on wifi in 2017........nonsense. 

Highlighted
Talent
Message 16 of 136
2,505 Views
Message 16 of 136

Re: Wifi Issues Oreo / Xperia-XZ-Premium

Lennyxz,

 

I completely agree with you.

 

The security concern about WEP should have nothitng to do the wifi connectivity issue, unless Google or Sony officially announce they don't support WEP

 

So after all, I think this is still Xperia or OS issue, but my post was simply to introduce walk around, not "fix".

Highlighted
Inhabitant
Message 17 of 136
2,500 Views
Message 17 of 136

Re: Wifi Issues Oreo / Xperia-XZ-Premium

Thanks and really appreciate your workaround at least it would give some assistance to people who may have a router at home using wep, will try and narrow it down by doing some more testing.

 

Just fed up after numerous support emails, phone calls and hours messing resetting phones that no one from Sony will admit there is a problem and just get on and fix it, very poor customer service. 

Highlighted
Inhabitant
Message 18 of 136
2,493 Views
Message 18 of 136

Re: Wifi Issues Oreo / Xperia-XZ-Premium

Ok spent sometime testing and I am having the same problem on wep and wpa encryption, defintely happening on my home wifi regardless as to whether it is wep or wpa. 

 

Sony please can you get on this!!! 

Apprentice
Message 19 of 136
2,482 Views
Message 19 of 136

Re: Wifi Issues Oreo / Xperia-XZ-Premium

Just got the same issue today. Updated to Oreo 1week ago. In my case even a reboot doesn't help. I simply cannot detect any nearby Wifi networks. Sometimes the detection comes back up for few seconds and then breaks again. 

Highlighted
Inhabitant
Message 20 of 136
2,478 Views
Message 20 of 136

Re: Wifi Issues Oreo / Xperia-XZ-Premium

Sorry to state the obvious but anyone having this wifi problem post oreo could they please log it officially with sony support so maybe they will actyally recogniae it exists and fix it.