account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Lockscreen does not "lock"

SOLVED
Learner
Message 1 of 4
1,368 Views
Message 1 of 4

Lockscreen does not "lock"

I have recently bought the new XZ premium, deep-sea black edition from Telstra in Australia, and have found a strange bug. 

 

I have enabled PIN and fingerprint security on my phone for unlocking. 

 

Pressing the power button turns off screen however, pressing the power button again shows the lockscreen. From here I can simply swipe up to unlock. 

 

I have enabled both lock after sleep with timer and lock immediately with power button from security/display settings menus. Neither have any impact. 

 

The only way to fully lock the phone is to turn on lockscreen and manually click the lock image on the bottom, which then yields the message that the phone was locked manually.

 

Am I missing something here or is this a scary security bug? Is there some "keep device unlocked" setting? 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Message 2 of 4
1,710 Views
Message 2 of 4

Re: Lockscreen does not "lock"

do you use Smart Lock? you can enable or disable it in Settings > Lock screen & security > Smart Lock. it disables PIN and fingerprint unlock when in certain locations or connected to certain devices.

View solution in original post

3 REPLIES 3
Highlighted
Message 2 of 4
1,711 Views
Message 2 of 4

Re: Lockscreen does not "lock"

do you use Smart Lock? you can enable or disable it in Settings > Lock screen & security > Smart Lock. it disables PIN and fingerprint unlock when in certain locations or connected to certain devices.

View solution in original post

Highlighted
Learner
Message 3 of 4
1,356 Views
Message 3 of 4

Re: Lockscreen does not "lock"

Thanks for the insight, looks like all the issues are due to the smart lock only with one of my devices... The Sony smartband talk. Removing the band from trusted devices fixes the lock but unfortunately removes its ability to receive notifications.

 

But since this stopped the locking issue, I will accept as answer! 

 

Thanks for the quick response and brilliant solution!! 

Highlighted
Message 4 of 4
1,351 Views
Message 4 of 4

Re: Lockscreen does not "lock"

glad I could help Slightly smiling Face I'm not sure if you can disable Smart Lock triggered by a trusted device (as I don't own any, heh) but if you can't then it's probably designed as a convenience feature. once your device loses connection with your watch it'll assume that you aren't around so that it'll require PIN or fingerprint again.