account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

wifi problem after.4.3 update on xperia z

Highlighted
One time poster
Message 111 of 155
1,478 Views
Message 111 of 155

Re: wifi problem after.4.3 update on xperia z

What I did was, I took the wpa_supplicant.conf from fw 4.2.2 and replace the one in fw 4.3 and now I can use my SW2 without losing my wifi connection.

Your device has to be rooted.
Use explorer with root excess.
It can be found in here on your device: /system/etc/wifi/wpa_supplicant.conf
Don't forget to reboot your phone
Highlighted
Regular
Message 112 of 155
1,425 Views
Message 112 of 155

Re: wifi problem after.4.3 update on xperia z

Has anyone from the UK been able to do this yet on an unlocked handset?

 

I have tried both PCC and SUS and both report that I have the latest firmware - even though I dont.

 

 

Highlighted
One time poster
Message 113 of 155
1,261 Views
Message 113 of 155

Re: wifi problem after.4.3 update on xperia z

Downloaded 10.4.1.B.0.101, but my email app still not working with wifi! It's f### slow!
Highlighted
Visitor
Message 114 of 155
1,240 Views
Message 114 of 155

Re: wifi problem after.4.3 update on xperia z

I have the same problem with ZL C6506...

 

If we set up a trendnet router in open wifi and lock it with mac acl, we can get the zl to connect via wifi, with the cisco, linksys, asus, dlink and netgear wag102 it will not connect either in open or wpa, wpa2, wpa+wpa2, with aes or tkip or both.

 

Bluetooth on/off, nfc on/off, airplane mode cycling, wifi cycling, power cycling, pc companion repair flash (5 times now) has no effect.

 

We seem to be missing the cryptography support for the wifi connection with this update... which was originaly done via sony's sus on the phone and same results from pc companion.

 

I don't want to root or unlock the phone to diagnose further.. sony online rep says to send the unit in and carrier (videotron) in canada refuses to repair, they only do replacement and since the zl is discontinued already, they will only replace with an "equivalent" which s the samsung s III which is smaller and is a downgrade of the camera sensor as well...

 

I'll gladly reward anyone who provides a working solution to me which does not void my warranty...

Highlighted
Regular
Message 115 of 155
1,191 Views
Message 115 of 155

Re: wifi problem after.4.3 update on xperia z

No joy - now have the latest update - doesn't appear to have fixed the initial problem with smartwatch (bluetooth) and wifi - still an either or situation can't have both on at the same time and be able to use wifi
Highlighted
Apprentice
Message 116 of 155
1,140 Views
Message 116 of 155

Re: wifi problem after.4.3 update on xperia z

Like the previous poster I too have had no joy with the latest update, which apparently " would fix" the sw2 / Xperia z wifi connection problems, they were telling porkies. Phone is exactly the same. I still have a dumbwatch rather than a smart one.
I get so many people commenting on the watch and how it works, or supposed to.
The best truly honest answer is that;" I can choose how I look at time "
Highlighted
Apprentice
Message 117 of 155
1,133 Views
Message 117 of 155

Re: wifi problem after.4.3 update on xperia z

It seems the update has arrived in the UK.

 

Just updated the phone, recharged the watch, gave it a reboot (hold power for 15sec) and so-far-so-good.  Been browsing, tweeting, facebooking and emailing with the watch connected. Of course, if it stops working the first thing I'll do is post here!

Highlighted
Apprentice
Message 118 of 155
1,111 Views
Message 118 of 155

Re: wifi problem after.4.3 update on xperia z

Same here.  Updated last night in the UK and all seems to be working fine now.  Fingers crossed there are no other issues I've not noticed yet.

Highlighted
Apprentice
Message 119 of 155
1,070 Views
Message 119 of 155

Re: wifi problem after.4.3 update on xperia z

Hi. I received a system update notification this morning in the UK and did it but build still shows as 10.4.B.0.569 and I still have the same issues. Have checked again for system updates and restarted phone but no success.
Inhabitant
Message 120 of 155
929 Views
Message 120 of 155

Re: wifi problem after.4.3 update on xperia z

I have the same problem with my ZR except downgrading wouldnt fix.and now even if my bt off every fewminutes its loses wifi.this is my second set due to this problem.Im tired of giving back to repair and getting same problem with a replacement..

 

I get this with MW600