account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests with the support app directly on your phone.
Read more and discuss the app here.

lack of 3g after system update

SOLVED
Highlighted
Rookie
Message 1 of 7
2,262 Views
Message 1 of 7

lack of 3g after system update

Hello :-)

 

It's problem with Xperia E dual

Few days ago I updated the system to the 4.1.1 version (compilation 11.3.A.1.39).

Unfortunatelly after updating I've discovered that smartphone don't works with 3G. On the display I've only icon "E". Before updating there was typically "H". Of course now the transfer is slower than before and of course I'm not happy of that.

I try to solve this problem - choose in menu list of available provider and... there are only 2G nets. Because I've functioning still in the same place of live and the problem has occured after the updating I'm sure that it's strictly connected.

Is there any solution for that?

Another problem is with trying to call. After system updating typically twice a day I have to restart smartphone because it's totally hanged. No one can connect with me and I can't call to anybody. Smartphone looks normally and doesn't give any siglan that something is wrong. But when I try to connect to somebody I direst the number and... there is no signal at all. After few seconds telephon return to main menu. There is also no record about this trial of connection in the list of done connections. It's very uncomfortable situation.

Sure, there are also some adventages with the system updating but problems mentioned above are really annoing.

Have you any solutions for it?

 

Thanks in advance.

Rafal

1 ACCEPTED SOLUTION

Accepted Solutions
Master
Message 3 of 7
2,495 Views
Message 3 of 7

Re: lack of 3g after system update

Have you set your phone on WCDMA/GSM? Settings > more > mobile networks > network mode. 

 

Please note that you can only set preferred network mode for SIM 1. SIM 2 can only run on GSM. 

sony_logo126x24.gif
What are your thoughts about this forum? Let us know by doing this short survey.

6 REPLIES 6
Forum Legend
Message 2 of 7
2,246 Views
Message 2 of 7

Re: lack of 3g after system update

Hi, try repairing phone software with PC Companion or Update Service.

http://www.sonymobile.com/gb/tools/pc-companion/

http://www.sonymobile.com/gb/tools/update-service/

Be aware that this will erase phone data completely, backup if necessary.

 

Before proceeding with software repair, confirm with your Network Operator that there is nothing wrong with the network. Also, remove and reinsert SIM card and try again (have a close look at the contact surface, ensure that it is relatively clean).

 

Don't forget to mark correct answer as Accepted Solution.
If you find the post helpful, press Kudos.

 

 

Master
Message 3 of 7
2,496 Views
Message 3 of 7

Re: lack of 3g after system update

Have you set your phone on WCDMA/GSM? Settings > more > mobile networks > network mode. 

 

Please note that you can only set preferred network mode for SIM 1. SIM 2 can only run on GSM. 

sony_logo126x24.gif
What are your thoughts about this forum? Let us know by doing this short survey.

Rookie
Message 4 of 7
2,224 Views
Message 4 of 7

Re: lack of 3g after system update

Alexander,

I've just checked it - SIM1 is in WCDMA/GSM mode.

Rookie
Message 5 of 7
2,217 Views
Message 5 of 7

Re: lack of 3g after system update

Wow! I've switched it between SIM cards!

I use internet only on SIM2.

And now... the first problem seems to be solved :-)

There is icon "H" and everything goes faster :-)

Thanks!

Rookie
Message 6 of 7
2,188 Views
Message 6 of 7

Re: lack of 3g after system update

gwhispererz,

Thank you for advice. As you can see, problem was solved in simpler way. But if some other problems occur in the future I will use PC Companion.

Thanks

Forum Legend
Message 7 of 7
2,173 Views
Message 7 of 7

Re: lack of 3g after system update

No problem, glad that your problem is sorted out by easier way. Slightly smiling Face

Great that you have came back to indicate the accepted solution which will benefit those with similar problem. :smileysmileywink:

 

Don't forget to mark correct answer as Accepted Solution.
If you find the post helpful, press Kudos.