account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Oreo Bluetooth issues (Problem with pairing etc)

One time poster
Message 371 of 382
1,592 Views
Message 371 of 382

Re: Bluetooth won't connect

i think it's about many android 8 devices, not only sony, i also read about xiaomi.

maybe there is an issue about avrcp1.3 ora they just don't care about bluetooth options and leave them stock

i checked on developer options and even activating facultative codecs it doesn't run, since i only have avrcp 1.4 1.5 1.6

Learner
Message 372 of 382
1,540 Views
Message 372 of 382

Re: Bluetooth will not stream music to 3M Peltor WS Alert XPI, but phone works.

Problem solved. 

3M have updated my Peltor WS Alert XPI and it works fine now. 

 

They have the same problem with some Samsung phones also. First Sony they have had a problem with. 

 

One time poster
Message 373 of 382
1,112 Views
Message 373 of 382

Re: Track information over Bluetooth (AVRCP) not updating.

https://drive.google.com/file/d/1qfwr0V3qQdeCEW_fagkpS5ePaYsg3yGV/view?usp=drivesdk

Sony xperia Xz1 dualsim 64giga

Jaguar Fpeace 2018

Intouchcontrol 8inch

Always trouble and connect/disconnect The bluetooth both with media and telephone, please help me.

 

Message 374 of 382
1,064 Views
Message 374 of 382

Re: No media sound from Bluetooth after update

I wanted to reply on this post as I also have the XA2 Ultra and have the exact same problem. The phone will pair with my aftermarket Pioneer radio but will not play any music. I am assuming it will work for calls but honestly I have not used it for that. Hopefully Sony will update and fix the media problem. V 50.1.A.18.83 as of right now

Highlighted
Pioneer
Message 375 of 382
1,060 Views
Message 375 of 382

Re: No media sound from Bluetooth after update

The user manual of my car tells me that when I receive an Android update I should reset Bluetooth settings.

2 ways to achieve that

In settings tap magnifying glass and type 'reset'. Find reset options and reset network settings. It includes WiFi settings, who cares.

Computers like resets very much, Android is no different from Windows in that respect.

Other option

Settings->apps & notifications ->see all apps, tap 3 dots upper right corner, show system->scroll to Bluetooth, ->storage->clear cache& data.

 

Let us know if one of these options helped you master Bluetooth connections.


who knows knows
who doesn't doesn't
Rookie
Message 376 of 382
979 Views
Message 376 of 382

Re: No media sound from Bluetooth after update

On my XPERIA XA1 Plus I encountered audio skipping via bluetooth. After many hours I found out that no skips occurred in the protected mode. So it had to be some app that caused problems. So I started to listen to sound via bluetooth stopping/deactivating apps to see if the skips would stop then.
Finally found that "ES Task Manager" seemed to cause the skips. Uninstalled it and no more bt audio skipping!

Regular
Message 377 of 382
793 Views
Message 377 of 382

Re: Bluetooth connecting issues on my car

Did all bluetooth connection issues (includes no sound, low sound quality during playback, sound title can't show on car display...) be fixed by Android 9.0 update. Can anyone who already upgraded to Android 9.0 share something about whether all bluetooth issue be fixed or not?

 

I am XZ2 user in Taiwan, I very desire to upgrade to Android 9.0 to fix the bluetooth issue I faced, however SONY still has not been released here until now.

Visitor
Message 378 of 382
756 Views
Message 378 of 382

Re: Oreo Bluetooth issues (Problem with pairing etc)

Try to restart your xperia phone and your Bluetooth headset or what so ever Bluetooth thing is and try gain pairing process..

Learner
Message 379 of 382
710 Views
Message 379 of 382

Re: Track information over Bluetooth (AVRCP) not updating.

I agree exactly  The bluetooth stability in the update is terrible. No track data is forwarded to the display when streaming music and it is not accepting input prompts with pause/play, skip track. 

 

I am not 1; patient enough to provide detailed bug information or technically savvy enough and 2; willing to do so because I believe it is the programmers reaponsibility. 

 

Prior the new system update it worked almost perfectly. I suggest reviewing the old coding or implementing it. 

 

My other complaint is that previously, the bluetooth output for volume seemed to identify which device was connected and the volume started where it was last used, whether that was supposed to happen or not I liked it. Can this feature be added to device connection re set volume for connected device (so I don't go deaf when connecting headphones, or have to adjust the volume from my phone, which is now slower process than before, whilst driving) 

Regular
Message 380 of 382
656 Views
Message 380 of 382

Re: Bluetooth connecting issues on my car

I am happy to say that the problem I faced (low sound quality during playback on car audio via Bluetooth) was solved completely after Android 9.0 update.