account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Oreo Bluetooth issues (Problem with pairing etc)

Highlighted
Moderator
Message 287 of 382
6,966 Views
Message 287 of 382

Oreo Bluetooth issues (Problem with pairing etc)

Anyone else had issues with Bluetooth since the 8.0 update, mine used to work perfect, but since 8.0 has had LOTS of pairing issues, and then when paired to something, regularly disconnects.

Anyone else?



Moderators are not affiliated with, or work for Sony Mobile, and their posts represent their own opinions and views.
Click here to find out more about the different roles on the community.

381 REPLIES 381
Enthusiast
Message 1 of 382
12,432 Views
Message 1 of 382

Track information over Bluetooth (AVRCP) not updating.

There seems to be a problem with track information update when streaming music over Bluetooth. I only get the title of the first song when the devices are connected. No update afterwards, all the controls are working (like play/stop, next/previous track) but the metadata information of track is not updated (it's like the title of the first song when the devices connected is frozen).

 

I stream music to my car radio. It is working fine with my Sony Z3 (Android 6.0.1), but on XZ Premium there is this issue with no updates for track information, it is really annoying. I hope you can fix this in next software update.

Sony Xperia Support
Message 2 of 382
12,396 Views
Message 2 of 382

Re: Track information over Bluetooth (AVRCP) not updating.

Hi @admad, sorry to hear about this.

 

Any chance you could capture this in a bug report? I could then forwarded it for investigation.

 

To do this:

1. Go to Settings > About phone > Build number, tap 7 times on the build number.
2. Go back and select Developer options then set Logger buffer size and change it to "4 MB".
3. Restart your phone, then replicate this.
4. Go back to Settings > Developer options, select "Take bug report" followed by "Interactive bug report".

 

When the report is ready you will receive a notification. Tap the notification to share it. I suggest you upload it to Google Drive and then choose to share a public link to the upload and include the link in the PM.

 

I'd also appreciate if you could include information about the car you connect to, such as brand, model and what head unit it has.

 

Thanks!

 

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Enthusiast
Message 3 of 382
12,377 Views
Message 3 of 382

Re: Track information over Bluetooth (AVRCP) not updating.

Hi @Christofer, thank you for the reply.

 

I've created a bug report and I sent it to you via PM.

 

My car is Renault Megane III Grandtour 2010 and the radio unit is Radiosat classic bluetooth.

 

I've also have video on how it works on Sony Xperia Z3 and Sony Xperia XZ Premium.

 

Here is Z3, as you can see track information changes along with the song, no problems.

https://youtu.be/GszcYDMTrUM

 

And here is XZ Premium, at first the bluetooth on phone turned off without any reason (0:43-0:44). Then, after turning it on again, it connected to the radio but the track information remained the same even when song changed. The bug report includes the situation from this movie.

https://youtu.be/r0EpIjCC5UA

 

Enthusiast
Message 4 of 382
12,368 Views
Message 4 of 382

Re: Track information over Bluetooth (AVRCP) not updating.

Mirror link for XZ Premium behaviour, thanks to ridicolous copyrights on youtube...

https://vimeo.com/221542522

Bluetooth turned off at 0:43-0:44, 1:18-1:26 song information not updated on car radio when changed.
Sony Xperia Support
Message 5 of 382
12,357 Views
Message 5 of 382

Re: Track information over Bluetooth (AVRCP) not updating.

Thank you! I'll forward this for investigation and I'll let you know here as soon as I know more. Slightly smiling Face

 

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Apprentice
Message 6 of 382
12,312 Views
Message 6 of 382

Re: Track information over Bluetooth (AVRCP) not updating.

Visitor
Message 7 of 382
12,216 Views
Message 7 of 382

Re: Track information over Bluetooth (AVRCP) not updating.

I'm also facing the same issue. My Sony xperia xz premium does not show information on hud of my car. Frequently disconnects. It worked perfectly for Sony xperia z2, my previous phone 

One time poster
Message 8 of 382
12,194 Views
Message 8 of 382

Re: Track information over Bluetooth (AVRCP) not updating.

I've got similar issues with XZ Premium and my car infotainment (Mazda MZD Connect present in recent Mazda cars). Before car's infotainment firmware update, I could not even finish phone pairing. After Mazda firmware upgrade (59.00.502) I can successfully pair phone, make phone calls and use media audio (car's audio controls do work). However song metadata is not displayed. It's working correctly with my Xperia Z3C, however this phone has AVRCP version 1.3 and XZ Premium has 1.6. 

Rookie
Message 9 of 382
12,160 Views
Message 9 of 382

Re: Track information over Bluetooth (AVRCP) not updating.

I've the same problem with my Xperia XZ (Android 7.1.1) and an Audi A3 (2015)... My old Xperia Z3 works fine with the AVRCP titles.