account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Oreo Bluetooth issues (Problem with pairing etc)

Adviser
Message 30 of 382
5,958 Views
Message 30 of 382

Re: XZ1 bluetooth woes

I would like to add to the complaint or annoyance that the mod stated. The bluetooth in my car connects however, the media controls don't work and constant dropped calls from Bluetooth stereo. I too spend 20 mins if not more time fiddling with connecting/reconnecting different devices. Another issue I'm having is GPS inaccuracy - basically navigation pointer while in navigation jumps to another parallel road atleast 4 times in a 30 minute drive. Please escalate this thread for just the Bluetooth issues even and I'll be happy. Coming from using galaxys for years, I'm pretty frustrated with the switch 

Apprentice
Message 31 of 382
2,253 Views
Message 31 of 382

Re: Bluetooth has stopped

Hi try to repair Software with  Sony PC Companion

https://support.sonymobile.com/gb/xperia-companion/

Here is how to use , so you will choose  your device .

https://www.youtube.com/watch?v=1LefMI67mIM

 

 

Good Luck Slightly smiling Face

Rookie
Message 32 of 382
2,232 Views
Message 32 of 382

Re: Bluetooth has stopped

Thanks for all replies.

After the last software update it has been stable without errors.

But today it started again. Will try repair.

 

Espen.

One time poster
Message 33 of 382
5,845 Views
Message 33 of 382

Re: XZ1 bluetooth woes

Can just confirm exactly the same behaivour described by Baigs786 in my car: Bluetooth connection in general isn't an issue but audio is not transfered to the car speakers, media controls don't work and track information isn't shown at the display. Just managed one time to get a working bluetooth connection after switching to Bluetooth AVRCP 1.5 - still this was just a very short time success. Now it is just again trying to connect/disconnect all the time in good trust to receive a proper connection again. Does anybody know more meanwhile about the status of this bug? Did anybody from Sony comment on that? Can we expect a patch soon?

Highlighted
Apprentice
Message 34 of 382
6,664 Views
Message 34 of 382

Re: Bluetooth issue XZ Premium

I'm also having trouble with the xz premium bleutooth. It connect, but there's no sound. I've experienced it with both my cars smartlink as with the mdr 100abn bluetooth headset. So I know something went wrong since the last android update. After restarting my phone it works fine, but restarting my phone twice or more daily is not ideal. How can this be fixed?

Adviser
Message 35 of 382
5,781 Views
Message 35 of 382

Re: XZ1 bluetooth woes

I'm starting to feel like most of the issues plaguing the Xperia XZ1 and XZ1 compact is Android Oreo related. I've read online somewhere about pixel having these issues as well. 

Inhabitant
Message 36 of 382
5,774 Views
Message 36 of 382

Re: XZ1 bluetooth woes

While that most possibly is true, it would still be nice if there would be any input from a Sony official- because Google is mum about the subject since Oct. 12, even though they know about the issues. 

Pioneer
Message 37 of 382
5,771 Views
Message 37 of 382

Re: XZ1 bluetooth woes


@Baigs786 wrote:

I'm starting to feel like most of the issues plaguing the Xperia XZ1 and XZ1 compact is Android Oreo related. I've read online somewhere about pixel having these issues as well. 


I suspect the same thing, because there seems to be quite a lot of "Oreo" (Android 8.x)-related issues at the moment, with a lot of different handsets... Looks like Google rushed things without the usual quality control.


  • I can't help you if you don't tell me what mobile device you're using & what version of Android it is running, in English (you can use Google Translate - http://translate.google.com).
  • The more information you can give me, the easier I can help you!
  •  Please kudo this post if you think it has been helpful; or mark it as the "solution" if it fixed your problem, so that other users facing the same issue can find the solution!
Visitor
Message 38 of 382
5,738 Views
Message 38 of 382

Re: XZ1 bluetooth woes

Same Problem with Bluetooth telephone calls in my car.  Bluetooth calls in my car drop after approx 20 seconds and it shows "no bluetooth" on the car-screen.

 

Pls fix!! 

Visitor
Message 39 of 382
2,179 Views
Message 39 of 382

Re: Bluetooth has stopped

Did the Sony companion help anybody?