account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Curious about what is happening at IFA?
Read more and discuss the press conference here.

Can not use USSD codes

SOLVED
One time poster
Message 121 of 271
698 Views
Message 121 of 271

Re: Can not use USSD codes

Strangely, if you send a ussd code, drop out of the dialer page, go back in and send the same ussd code it completes the request. A painful way to check you balance but at least it works (if you are quick enough).
I have to say that it is very disappointing that Sony have not replied or made any statement towards what is obviously a global issue with their latest roll out. How do they expect to retain customers in a fierce smart phone market when they do not even reply to their customers on their own forum!

Sort it out Sony, it should not take us (the customers) to get a workaround in place.

I hope this helps some of you
Apprentice
Message 122 of 271
645 Views
Message 122 of 271

Re: Can not use USSD codes

And one more thing i notice is, before upgrade to 5.1.1 my both sim card were clearly mention in dial pad.

After upgrade, just one sim was mention and the other just CARD 2 or CARD 1.

SONY please give us solution or any news. 

 

One time poster
Message 123 of 271
644 Views
Message 123 of 271

Ussd code error

Hi everyone.
After last update in my phone
I can't use ussd code
After write ussd code i can't see anything
Or get this error ( conniction problem or invalid code )
But i have connect to network and i can do call
Please help me .
What is the problem
How can i fix it ?

Regards
AboudAtt
Emperor
Message 124 of 271
641 Views
Message 124 of 271

Re: Ussd code error

@Abodatt

 

It has been reported before

 

http://talk.sonymobile.com/t5/Software-Updates/Can-not-use-USSD-codes/m-p/1019027#U1019027




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Apprentice
Message 125 of 271
584 Views
Message 125 of 271

Re: Can not use USSD codes

Dear sony,

This afternoon my phone totally rubbish.
It get turn off and on itself several time until the phone became very hot.
It keep on and off itself at sony xperia windows screen.
Oh come on, this is very frustating.
I just use whatsapp for today and suddenly became like this after im not using it.
This 5.1.1 update is disaster.
So what can i do to my phone??
Should i throw it away!!
Thanks sony for making my day.
Please think about this and take this as urgent case.
I buy it using money not leaves.
Adviser
Message 126 of 271
619 Views
Message 126 of 271

Re: Can not use USSD codes

Please wait while we find an agent to assist you...
You are currently in position number 1 in the queue.
You have now been connected to an agent.
Jess:  Hi Andres, thank you for contacting Sony Xperia UK Chat Support. My name is Jess, please could I take your full name and email address?
Andres Moya:  -----
Andres Moya:  ********
Jess:  Thank you for providing me with this information, Please could you confirm which model of phone you have and which network it is on?
Jess:  Thank you for providing me with this information, with regards to the query you posted if the USSD codes are not working following the update then you will need to contact your network provider regarding this for details on how you can check your balance.
Andres Moya:  In brief. I was not very carefully check forums before upgraded Z3 Dual from 5.0 to 5.1. Bug was clearly reported on forums. Now I am in the same boat
Andres Moya:  NO. it is not
Andres Moya:  this is standard answer. USSD codes was working on 5.0 will all carriers. USSD code are not working with all carriers on 5.1
Jess:  That is not true, USSD codes do actually work. There are some issues with non-UK network providers.
Jess:  But for the most part, these are working for handsets on 5.1
Andres Moya:  does your knowledge base indicate that bug acknowledged and fix will be delivered in next release.
Andres Moya:  ?
Andres Moya:  Ok. What uk carriers USSD codes working with? I will buy SIM to try
Jess:  All I can suggest is that you contact your network provider regarding this as it is a network specific issue and not a fault with the update. Network providers ammend the software before it is rolled out to handsets on their network.
Andres Moya:  Also dual SIM is for people who travel a lot. Please write down following carriers to not working list:
Andres Moya:  DigiMobil Spain
Andres Moya:  INWI Morocco
Andres Moya:  it is very inconvenient to borrow phones from friends especially for nanoSIM Slightly frowning Face
Jess:  I cannot provide a list of carriers that would work with your handset as it is not a UK handset and you are not based in the UK Andres. You must contact your network provider regarding this issue. I apologise for any inconvenience this causes you
Andres Moya:  device designed for travellers cost 500GBP and has no support? ]
Andres Moya:  ok
Jess:  Alternatively, you could contact the local Sony Xperia support team for your country for further advise
Andres Moya:  It was purchased on ebay. UK or German supplier. don't remember now. local support team unable to speak English
Andres Moya:  never buy from Sony, especially expensive hardware
Andres Moya:  never install updates
Jess:  It would not be a UK handset as the Xperia Z3 Dual is not a UK model
Andres Moya:  thank you
Andres Moya:  bye bye
Andres Moya:  Wrong wrong
Jess:  Thank you for using the Sony Xperia Chat Support today. Have a nice day Slightly smiling Face
Your session has ended. You may now close this window.
Highlighted
Adviser
Message 127 of 271
677 Views
Message 127 of 271

Re: Can not use USSD codes

Seems that Dual is a rare phone, and not all regional support teams can help.

Anyone found what firmware work with it?

 

Tried to reflash to HK version as someone suggest earlier HK phone works. Customization 1289-8620 to 1290-5630. Phone shows different behaviour on USSD requests, but still unable to use USSD.


Another isse that if i enter number in dialer and press to call SIM2, popup window appears that ask again if i want to use SIM1 or SIM2. If one sim disabled, that window still try to popup and then disappear before call started. Is it only with me? Could it be related to some other voip dialers installed like skype etc.

 

Will try to reflash back to 5.0.

Apprentice
Message 128 of 271
634 Views
Message 128 of 271

Re: Can not use USSD codes

Guys, I think you should downgrade your firmware back to KitKat 4.4.4 since there are no help or response from SONY how to solve these issues! I already did and its smooth sailing with KitKat!

Adviser
Message 129 of 271
698 Views
Message 129 of 271

Re: Can not use USSD codes

Flash few more customisations of latest versions. Tried to reset to factory deafaults and run tests with few sims. USSD codes are running but result in no output. I think scratch cards topups even possible, but i don't have. Nothing comes back on the screen after USSD sent. Interactive USSD menus are timeout out. Will now downgrade to 5.0 or 4.4.4. Unfortunately all apps and settings will be lost.
Actually, nothing to complain, why am i want to try update in the first place? Slightly smiling Face Maybe too much free time Slightly smiling Face

Adviser
Message 130 of 271
762 Views
Message 130 of 271

Re: Can not use USSD codes

Untitled.png



5.0 works 4.4.4 works. note that for central Europe there is no 5.1 firmware and for some countries even there is no 5.0. See attached screenshot from flashtool. So it maybe true that carriers need to update something on their protocols. To all who affected, please use flashtool to downgrade, you will however need to clean your apps and data as there is no downgrade process for them.