account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

smartband 10 Bluetooth unlock on Z3 doesn't work

SOLVED
One time poster
Message 31 of 77
2,804 Views
Message 31 of 77

Re: smartband 10 Bluetooth unlock on Z3 doesn't work

same thing for both of my SmartWatch and smartband. what I found ironic is Bluetooth unlock is a base feature in Google lollipop. Lollipop itself offers the option to add Bluetooth devices to unlock phone, something that sony already had. why would sony customize lollipop to not support it is beyond even the realm of madness.
Inhabitant
Message 32 of 77
2,781 Views
Message 32 of 77

can't use SWR 10 in smart lock

Even after connecting SmartBand, smart lock is not showing SmartBand in Bluetooth devices. But smart lock recognizes SmartBand in NFC mode . And smart lock works only when NFC is ON and SmartBand should be nearer to this NFC detection area of phone. But smart lock is not showing my SmartBand in Bluetooth devices. As in case of kitkat it was showing SWR10 is available to use smart lock option and kitkat was also showing distance range to unlock phone.

But in lollipop SmartBand must touch NFC area to unlock. And smart lock is not recognizing SmartBand as Bluetooth device.so im feeling trouble to use new smart lock which is developed by Google, Sony's Bluetooth unlock was good compared to smart lock of Google.
How to fix this problem?
Sony Xperia Support
Message 33 of 77
2,779 Views
Message 33 of 77

Re: can't use SWR 10 in smart lock

I'm afraid i have no solution for this but it's something that's been forwarded internally as feedback.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Inhabitant
Message 34 of 77
2,764 Views
Message 34 of 77

Re: smartband 10 Bluetooth unlock on Z3 doesn't work

@Rickard sir. Bluetooth unlock which was in kitkat and which was provided by Sony was showing MAC address and name of Bluetooth devices available. That was portable and easier than smart lock.
Why that Bluetooth unlock is absent in lollipop?
Visitor
Message 35 of 77
2,748 Views
Message 35 of 77

Lifelog with Android Wear

Currently I'm using Lifelog on my Sony Xperia Z2 with a Smartband SWR10. Unfortunately after I updated to Lollipop the SWR10 does not unlock my Z2 any more. I'm thinking about switching to an Android Wear Device from another manufacturer (eg. Huawei Watch or LG G Watch R). Does Lifelog on my Z2 also work with other Android Wear devices or has it to be a Sony device (SWR50)?

Visitor
Message 36 of 77
2,747 Views
Message 36 of 77

Re: smartband 10 Bluetooth unlock on Z3 doesn't work

I sent a mail to the german Sony support and they answered that Lollipop brought some changes (including this one) that can not be changed. They have no solution other than take it as it is. 

 

On one hand this is not dramatic, on the other I see no reason to stick to the Sony universe any more.

Apprentice
Message 37 of 77
2,716 Views
Message 37 of 77

Re: smartband 10 Bluetooth unlock on Z3 doesn't work

Do as followed:

1) Go into settings -> apps -> Smartband -> Stop now (I am on Dutch, but button will look like this somehow) Slightly smiling Face

2) Go into settings -> Bluetooth -> Connect to SWR10

3) Probably as long as you don't have Exchange working via Gmail it should ask you if you want to set it as a trusted device

 

When I didn't have Exchange working via Gmail this worked for me till I got to far for my phone with the Smartband, after restarts and sometimes after sleeping. At those times I had to unpair, and start the procedure from above again.

 

Hope it helps.

Highlighted
Moderator
Message 38 of 77
2,685 Views
Message 38 of 77

smartband not showing after lollipop

OK so phone will still talk to smartband, but does not show in Bluetooth devices once phone power goes off and back on,
Wouldn't bother me(as they still log details and sends notifications) but because it doesn't show in Bluetooth devices, smart lock won't work after phone has reset.
Only way to do it is to uninstall and reinstall smartband every time I turn phone off and on. (and setting it all up again)
Amy ideas?


Moderators are not affiliated with, or work for Sony Mobile, and their posts represent their own opinions and views.
Click here to find out more about the different roles on the community.

Moderator
Message 39 of 77
2,679 Views
Message 39 of 77

Re: smartband 10 Bluetooth unlock on Z3 doesn't work

The post above my post above works.
SWR10 hides itself from Bluetooth devices once paired and only way to bring it back is to force close SWR10 app and then Re pair in Bluetooth settings.
What a pain,
Easy fix for Sony, update either smartband fw or phone fw to allow Android to see the SWR10 on reboot for 30 seconds.
Bet it don't get done tho


Moderators are not affiliated with, or work for Sony Mobile, and their posts represent their own opinions and views.
Click here to find out more about the different roles on the community.

Apprentice
Message 40 of 77
2,554 Views
Message 40 of 77

Re: smartband 10 Bluetooth unlock on Z3 doesn't work

Okay, for all those who keep posting the "Force stop" connection method. I think we all know that it works, but we want a real solution. Not a "fix" that takes a couple of minutes to set up and has to be renewed everytime I am a couple of yards away from my phone. Obviously this is a major problem and there are a lot of disappointed users. Please release an update soon! thanks