account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

Smartband SWR10 not recieving alarm notifications from Xperia XZ Premium

One time poster
Message 1 of 9
2,431 Views
Message 1 of 9

Smartband SWR10 not recieving alarm notifications from Xperia XZ Premium

Just wondering if anybody can help me with this as all the settings are there but when the alarm goes off on my Xperia Xz premium my Smartband SWR10 would t vibrate. 

8 REPLIES 8
Highlighted
Learner
Message 2 of 9
2,333 Views
Message 2 of 9

Re: Smartband SWR10 not recieving alarm notifications from Xperia XZ Premium

I'm afraid that I cannot help but I thought I would add fuel to your fire, I have an Xperia XZ and I performed the Android 8 upgrade last night and promptly wound up late for work due my vibrating alarms no longer triggering the smartband. Please fix this Sony? 

Moderator
Message 3 of 9
2,323 Views
Message 3 of 9

Re: Smartband SWR10 not recieving alarm notifications from Xperia XZ Premium

@Simacparbri@Stormlion90 do you have smart connect installed? It holds the smartband settings where you can also find vibrate with alarm.



Moderators are not affiliated with, or work for Sony Mobile, and their posts represent their own opinions and views. Click here to find out more about the different roles on the community.

Learner
Message 4 of 9
2,312 Views
Message 4 of 9

Re: Smartband SWR10 not recieving alarm notifications from Xperia XZ Premium

Hi Alexdon. 

I had the Smartband software and the smart Connect software installed on the phone but it didn't seem to help, I have tried reinstalling the apps and changing the settings from audible to vibration but nothing seems to allow the alarm to trigger on the band. Both apps asked on reinstall if I wanted them to interact with the phone, but it hasn't fixed the problem.

I think that it might be something to do with the new Background running app that is on Android 8 for me, as the band only shows that it can interact with the Telephone and make changes to the SD Card, there is no mention of the device being able to set alarms or interact with the phone in any other way. Furthermore, there doesn't seem to be a way to stop the app from running in the background allow it full interaction with the phone.

Any help would be great on this thanks. 

SiM 

Moderator
Message 5 of 9
2,301 Views
Message 5 of 9

Re: Smartband SWR10 not recieving alarm notifications from Xperia XZ Premium

@Simacparbri@Stormlion90 those are the only permissions for SB. Let me try to get more info on this.



Moderators are not affiliated with, or work for Sony Mobile, and their posts represent their own opinions and views. Click here to find out more about the different roles on the community.

One time poster
Message 6 of 9
2,142 Views
Message 6 of 9

Re: Smartband SWR10 not recieving alarm notifications from Xperia XZ Premium

Also not recieving alarm notifications on Xperia XZ. Only since Oreo upgrade. Downloaded a new alarm App and gave the smartband notification access from the new app. Still didn't help. 

One time poster
Message 7 of 9
2,072 Views
Message 7 of 9

Re: Smartband SWR10 not recieving alarm notifications from Xperia XZ Premium

My theory is the updated alarm/clock app in Oreo doesn't support the SmartBand and Sony aren't going to fix that because the products were discontinued. The one feature I found invaluable now broken.

One time poster
Message 8 of 9
1,517 Views
Message 8 of 9

Re: Smartband SWR10 not recieving alarm notifications from Xperia XZ Premium

Got a XZ Premium with Oreo. Android 8.0.0 version. And SWR10 smartwatch.

Vibration worked after I enabled it again. Try to go into:

1: Smart connect

2: select accessories. (Activities is open)

3: Select smartband

4: select Smartband again (settings)

5: Alarm show up there make it active as vibrate.

 

I'm using Sony alarm app so I got same phone, wristband, android version and alarm app

 

 

One time poster
Message 9 of 9
1,379 Views
Message 9 of 9

Re: Smartband SWR10 not recieving alarm notifications from Xperia XZ Premium

I've installed latest 4.1.3.A.2.107 firmware to my XZ yesterday and tis morning I was surprised. Alarm notification works like a charm again. Thank you SONY 😁