account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Media sound not working in Xperia P

SOLVED
Highlighted
One time poster
Message 11 of 13
400 Views
Message 11 of 13

Re: Media sound not working in Xperia P

Hey, I have the same phone if it's still not working after unplugging your headphones, try leaving your headphones in and restarting the phone with them still connected. 

Highlighted
One time poster
Message 12 of 13
222 Views
Message 12 of 13

Re: Media sound not working in Xperia P

For anyone having this problem, I've had it twice and this is what I've found:

 

With both the times its happened to me there's been water in the headphone jack so it thinks there's headphones, then not, then headphones, then not etc. so it keeps cancelling the sound. If you ether leave it pong enough or try to dry out the headphone jack it should work.

Rookie
Message 13 of 13
102 Views
Message 13 of 13

Re: Media sound not working in Xperia P

I just ran a graphite pencil inside the speaker/headset port. It worked. I learned this from another site that said to put graphite powder in and shake out the excess. I don't have graphite powder  but I have a pencil and as soon as I did I, I could hear sounds coming out from the speaker again! I have an Xperia xa1 ultra.