account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Illumination Bar

SOLVED
Highlighted
Inhabitant
Message 1 of 13
3,027 Views
Message 1 of 13

Illumination Bar

I have a Sony Xperia SP and cannot believe there is not a simple way to switch the Illumination bar off and on!!

If I leave my phone on overnight I do not want a light constantly flashing, nor if I am in a meeting or driving as it is very distracting.

I have tried several apps which have been suggested would switch this light off (Night mode, Illumination Bar) but none have worked and end up over riding the customisation of the light e.g. only one colour available for incoming sms rather than choosing different colours for different contacts so this totally defeats the purpose of having the light in the first place surely!

This is my 4th Sony phone and generally I love them, in the past the light has been a bit more discreet and on turning the phone face down it was hidden but the illumination bar shines whichever way you put the phone.

I don't want to disable this completely, just have a nice simple shortcut from the homescreen like for wifi etc where you can switch light notifications off when required. Does anyone know if there is such a thing? Or is there any chance of Sony adding this in a future update? Otherwise I am considering looking at another handset.

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
One time poster
Message 7 of 13
3,876 Views
Message 7 of 13

Re: Illumination Bar

I have managed to fix this - I disabled notifications in Settings > Display > Light effects, then use the "Illumination Bar Notification" app. You can customise the colours for different apps notifications, and set "Off Hours". Works a treat! Just make sure you turn off notifications in the phone's settings first!

View solution in original post

12 REPLIES 12
One time poster
Message 2 of 13
2,908 Views
Message 2 of 13

Illumination bar not pulsating anymore

Ever since updating my phone to 4.1.2 ages ago the illumination bar hasn't been the same since, it'll only flash ever few seconds when on charge instead of pulsing all the time like it used to. Anyone else had this problem? is there a fix?

Cheers guys.
Highlighted
Commissioner
Message 3 of 13
3,017 Views
Message 3 of 13

Re: Illumination Bar

You can turn off the illumination bar by going into settings>display>light effects>notifications.
Highlighted
Inhabitant
Message 4 of 13
3,011 Views
Message 4 of 13

Re: Illumination Bar

Thanks. I had tried that but it didn't seem to work before. I think it was possibly being over-ridden by one of the other apps. I've now uninstalled all other apps and will try this again.

It would still be useful to be able to have a shortcut to do this rather than go in via settings.

Highlighted
Commissioner
Message 5 of 13
2,999 Views
Message 5 of 13

Re: Illumination Bar

Unfortunately there is no shortcut to do this.
Highlighted
Learner
Message 6 of 13
2,887 Views
Message 6 of 13

Re: Illumination bar not pulsating anymore

Not had this problem but have you checked your settings and see if vibrate has been turned off? Also check its not on Airplane mode this will turn off sences and lots more

Also check to see if you have put your phone on Save Battery mode or Stamina Mode? this will turn functions off with use still of your phone your find this in Settings - Power management


Also last thing i can suggest is Settings - Sound - Vibrate on touch etc

                                                         Settings- Display etc

 

Somethings been turned off i would assume is the problem as you said it does do this but not fully. So it works but has been disabled or half disabled lol

 

Hope you figure out and if you do Post how you did it Just to help others  Slightly smiling Face

Highlighted
One time poster
Message 7 of 13
3,877 Views
Message 7 of 13

Re: Illumination Bar

I have managed to fix this - I disabled notifications in Settings > Display > Light effects, then use the "Illumination Bar Notification" app. You can customise the colours for different apps notifications, and set "Off Hours". Works a treat! Just make sure you turn off notifications in the phone's settings first!

View solution in original post

Highlighted
Inhabitant
Message 8 of 13
2,937 Views
Message 8 of 13

Re: Illumination Bar

Thanks markym. I've tried illumination bar notification app but it wouldn't switch the light off. It was probably because I hadn't turned it off in the phone settings. I might give it continues go but the other issue I had with it was that I was unable to keep the customisation of sms notifications. I use handcent sms app which I love but lost some of its notification features.
Highlighted
Message 9 of 13
2,838 Views
Message 9 of 13

Re: Illumination Bar

you can use full version (paid)

in that version you can add other apps to light on the illumination bar


i have this app and my phone light effects are on..but app is not overriden by handset light effects

 

Highlighted
Inhabitant
Message 10 of 13
2,789 Views
Message 10 of 13

Re: Illumination Bar

I've tried downloading the Illumination bar app again and this time switching off the phones own light effects. I've added Handcent to the list of apps and so far so good! All seems to be working much better. 

Thanks for all the comments.