account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Xperia M dual speaker not working,(no ringtone, no audio and video output on speaker)

Highlighted
One time poster
Message 11 of 21
6,161 Views
Message 11 of 21

Re: Xperia M dual speaker not working,(no ringtone, no audio and video output on speaker)

Thanks, my Xperia now working perefect, i got the needle and do what you say. Perefct!

Highlighted
One time poster
Message 12 of 21
6,077 Views
Message 12 of 21

Re: Xperia M dual speaker not working,(no ringtone, no audio and video output on speaker)

I found that small hole on bottom right but its only a reset where you can delete unwanted apps. The sound / ringing issue remains.

Highlighted
One time poster
Message 13 of 21
5,937 Views
Message 13 of 21

Re: Xperia M dual speaker not working,(no ringtone, no audio and video output on speaker)

sir

i have made repair many mor times

The problem is not solved

every time going for service center is headache

plz gine me solution for that

regards

baliagr

Highlighted
One time poster
Message 14 of 21
5,767 Views
Message 14 of 21

Re: Xperia M dual speaker not working,(no ringtone, no audio and video output on speaker)

This solved my problem but when I got back out of safe mode it stops again?!
Highlighted
One time poster
Message 15 of 21
5,410 Views
Message 15 of 21

Re: Xperia M dual speaker not working,(no ringtone, no audio and video output on speaker)

Charlie you realy are the boss, my sister phone is fixed, i'll buy you a drink?
Highlighted
One time poster
Message 16 of 21
5,251 Views
Message 16 of 21

Re: Xperia M dual speaker not working,(no ringtone, no audio and video output on speaker)

I can't find the litlle hole, im just able to see the mic hole.
.
Enthusiast
Message 17 of 21
5,135 Views
Message 17 of 21

Re: Xperia M dual speaker not working,(no ringtone, no audio and video output on speaker)


Model: C1905
FW: 15.4.A.1.9
Root: Yes

I just had an Xperia C1905 speaker failure.
The built in speaker would not work and no sound could be heard with volume up and ear to the speaker grill.
If one used headphones, music played just fine.

I read some of the comments, like putting phone into safe mode, shaking it, pushing an object into the mic 'hole' at the bottom right of the screen.
None of this worked.

I stripped the phone down and looked at the speaker mount on the Xperia C1905.
The speaker is isolated from the main ANT board and is part of the removable plastic sub-cover.
Looking at this, there are two pins that make a connection onto the ANT board. If these contacts are not made cleanly the speaker will not work.

This may explain why some people have had success with a) shaking the phone, b) press the ANT board through the mic hole.

The pressing and shaking could have re-establish the speaker pin contacts again, but not the best way to solve this if my theory is correct.


The best option is to 'rise' the two speaker connection pins gently so a better connection can be made.
I also used a nail file and gently cleaned the two pin heads.

Started the phone in safe mode and entered *#*#SERVICE#*#* and tested speaker, it works again.


Rebooted in "normal" mode and checked the Xperia Music player and the speaker was working again.


So, this may not be the complete answer, but does add weight to the thought it could just be the speaker contacts.

 

Update

 

Failed again, This time I pulled the speaker out of it's resessed mount and inspected it.

The contact pins can not be raised any further than they are due to design.

 

By pulling the speaker out of it's mount it seperates the 'spounge' seal around the base of the speaker.

Re-seating the speaker means it's very slightly higher as the 'spounge' is now 'unsettled' and thus raises the speaker up and thus could/should improved pin contact back onto the ANT board.

 

Re-seated the sub-cover, screwed it in and the speaker is going again.....

New thought, maybe the spounge seating compresses over time and thus could reduce the contact pins ability to make a contact

Highlighted
Visitor
Message 18 of 21
4,373 Views
Message 18 of 21

Re: Xperia M dual speaker not working,(no ringtone, no audio and video output on speaker)

not helpful. I think your solution may probably damage the phone.


@CharlieTheBoss wrote:

Problem completely solved!!

I was having exactly the same problem! I bought my Xperia(M) last year. since its been working pretty well.But today morning all-on-a-sudden external speakers stopped working! Though I was able to talk as the internal speakers were well working. I tried to play musics from Walkman, MX Player, power Amp but as everybody's complaining there was no ringtone, no audio and video output on speaker. I tried out safe mode but It still the same! No **bleep**in' sound!!
finally (or co-incidentally) i found the solution..... here are the steps you're gonna have to follow to get your speaker's output back>>
1> play a song from walkman
2> make sure that at highest volume no sound is coming out from speaker
3> look..... there's a very small hole at the very right bottom of phone screen
4> now take a ball pen or a needle (ball pen is more preferable) and put that into the tiny hole
5> push the ball pen vertically downwards untill sound comes out from speaker!!!
6> while pushing(approx. 2 seconds) you will see that your dead speaker's just got magically alive!!



@CharlieTheBoss wrote:

Problem completely solved!!

I was having exactly the same problem! I bought my Xperia(M) last year. since its been working pretty well.But today morning all-on-a-sudden external speakers stopped working! Though I was able to talk as the internal speakers were well working. I tried to play musics from Walkman, MX Player, power Amp but as everybody's complaining there was no ringtone, no audio and video output on speaker. I tried out safe mode but It still the same! No **bleep**in' sound!!
finally (or co-incidentally) i found the solution..... here are the steps you're gonna have to follow to get your speaker's output back>>
1> play a song from walkman
2> make sure that at highest volume no sound is coming out from speaker
3> look..... there's a very small hole at the very right bottom of phone screen
4> now take a ball pen or a needle (ball pen is more preferable) and put that into the tiny hole
5> push the ball pen vertically downwards untill sound comes out from speaker!!!
6> while pushing(approx. 2 seconds) you will see that your dead speaker's just got magically alive!!




Highlighted
One time poster
Message 19 of 21
3,903 Views
Message 19 of 21

Re: Xperia M dual speaker not working,(no ringtone, no audio and video output on speaker)

Im tired nothing...
Highlighted
One time poster
Message 20 of 21
2,262 Views
Message 20 of 21

Re: Xperia M dual speaker not working,(no ringtone, no audio and video output on speaker)

after pressing the pin in the hole , it works few hours...then same problem occured