account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Problem with GPS

Highlighted
Visitor
Message 1 of 48
45,928 Views
Message 1 of 48

Problem with GPS

Hi

 

I have problem with using of GPS. When I am using my endomondo it fixed the location, but after few minutes it just loses the gps signal on the open road under clear sky and looks like it remains in search mode. It never fix position again. I need to manualy disable GPS. And after enabling it will fixed within few seconds. Unfortunatelly this problem occurs randomly and always I have to do this GPS disable/enable procedure. And this is really annoying.

 

Similar behaviour happen with other software like Sygic navi or GPS test

 

 

Is there any help? New firmware? Anything?

 

 

I am using Xperiam M Dual

model c2005

android 4.2.2

kernel 3.4.0

build number 15.2.A.1.12 (latest in our country)

 

Thank you

 

47 REPLIES 47
Highlighted
Rookie
Message 2 of 48
45,887 Views
Message 2 of 48

Re: Problem with GPS

I have the same problem.

 

I have done like mentioned in the support forum, GPS.

 

I also installed the APP AndroiTS GPS Test Free (very good!) to see the status and signal strength of the GPS.

 

All was working well, good signal and more than 10 satellites (also in car and inside a building).

Have tested it and it worked well.

But suddenly no signal any more. Sometimes it is working a long time, sometimes it crashes after some minutes.

I had to switch GPS OFF, wait some seconds and switch GPS ON again and it works again.

 

For me it looks more like a software problem, hardware seems to work with good sensitivity.

Highlighted
Rookie
Message 3 of 48
45,881 Views
Message 3 of 48

Re: Problem with GPS

Highlighted
Rookie
Message 4 of 48
45,857 Views
Message 4 of 48

Re: Problem with GPS

Hi,

 

I have tested 3 days to find out what the problem with the GPS is.

I used the APP Androids GAPS Test Free to see the status and signal strength of the GAPS.

 

Before I have done like mentioned here:

http://talk.sonymobile.com/t5/FAQ/GPS/m-p/351902#U351902

 

If I use the GPS at fixed positions like in my office the sensitivity of the GAPS receiver is good.

Have tested it in car and it worked well, too.

 

The problem happens only if the GAPS signal is lost.

Then the EXPIRE M dual can not find the GAPS again.
Sometimes you can see 1 or 2 satellites, but not more.

 

If you switch GPS OFF, wait some seconds and switch ON again it works until it looses the satellites.

To simulate loosing of satellites I have put the XPERIA into a good shielding metal box.

Every time I have done this the GPS crashed and had to be restarted.

 

Seems to be a software problem if the connection to the satellites is lost.

Looks like it searches with lower sensitivity ???

 

Has anyone else the same experience?

 

Stephan

Highlighted
Visitor
Message 5 of 48
45,832 Views
Message 5 of 48

Re: Problem with GPS

It looks like that nobody from SONY would like to solve this issue. This problem is known for more than half year and we still do not have solution. Even though the GPS is not usable. 

 

I am going to return this phone and buy different dualsim.

 

 

Highlighted
Adviser
Message 6 of 48
45,790 Views
Message 6 of 48

Re: Problem with GPS

I contacted Sony both through the contact form on their website and by calling up their UK help centre and in both cases the best support I could get was that Sony was not aware of any issues with Xperia GPS and that I should 'Repair' my phone using the instructions below (these were emailed to me):

 

"Thank you for contacting the Sony Xperia support centre.

 

We are sorry to hear of the issues you are experiencing with GPS on your Sony Xperia M.

 

We would suggest that you try to perform a repair of the software using PC Companion. If the issue is related to a problem with your software this will be repaired and your handset will work as intended. To do this, you will need to install PC Companion from the Sony Xperia website. Please follow the steps below to do this:

 

1. Go to sonymobile . com

2. Select Support

3. Choose your handset from the drop down list

4. Select "View All Software Updates"

5. Download for PC

6. Check the requirements and then "Download PC Companion"

 

To then perform a repair on your handsets software, please follow the steps below:

 

1. Open PC Companion

2. Start 'Support Zone'

3. Select Phone Software Updates

4. At this point a pop up will appear on screen asking you to connect your handset while powered on, as the software repair needs the handset to be switched off please ignore these connection instructions and click on the blue link which states "Repair Phone”

5. Some on screen steps will now appear for you to follow. Please also connect the handset when you are prompted to do so.

6. When you are asked to connect the handset (still with the phone powered off) please press and hold the key stated on screen for 30 seconds before connecting the handset and keep it held down as you connect

7. The repair process should now begin.

 

Please ensure your handset is not connected to your PC when performing the above as you will be instructed to connect your handset once you have followed the above steps. Your handset must also remain powered off at all times.

 

Please note it may be the case that user data is lost during this upgrade. We therefore recommend backing up any data to your SIM card, Memory Stick, or PC before upgrading.

 

Please be aware that if an update to a later version of Android has become available for your Sony Ericsson Xperia handset the new version may be installed. If this is the case you may notice some differences in the functionality of your handset when updating. All information regarding these changes can be viewed on the following link. We would recommend reading through this before updating."

 

Has anyone else tried 'repairing' their phone and if so did this fix the problem for you?

Highlighted
Visitor
Message 7 of 48
45,761 Views
Message 7 of 48

Re: Problem with GPS

Same problem for me with the Xperia M single SIM

 

The sensitivity of the GPS is good, but after 5-10m or after passing under a bridge, the GPS signal is lost and never come back...

 

I have call the Support, they say that I have to use the update service, but I'm not sure that it will resolve the problem...

 

An other call to the support, and they say that I have to return my phone... But I'm sure that this is not a hardware problem!

 

If somebody has a solution...

Visitor
Message 8 of 48
45,701 Views
Message 8 of 48

Re: Problem with GPS

I have tried upper mention process with reinstaling software with PC companion. But after succesfull repair there is still same behavior of GPS.

 

Rapair do not help with GPS problem.

 

 

Highlighted
Rookie
Message 9 of 48
45,661 Views
Message 9 of 48

Re: Problem with GPS

I have the same experiance, all the infos from support center did not solve the problem.

 

Only restarting GPS helps (sometimes for some minute only).

I think it is a software problem because after restarting it works until the GPS signal is lost again.

 

 

 

Highlighted
Adviser
Message 10 of 48
45,334 Views
Message 10 of 48

Re: Problem with GPS

From my reading it seems as though this is a Jellybean bug - http://www.androidcentral.com/psa-galaxy-nexus-gps-problems-jelly-bean-theres-easy-fix

 

There is a fix in that article for the  Samsung Galaxy Nexus and perhaps it could work for the Xperia M, I just updated my phone to Jellybean 4.3 yesterday and tried the fix mentioned in the article linked above but have yet to test out my GPS, I'll update if I experience the same problem again.