account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Welcome to the Open Devices community!

This is where we discuss open source and development related questions on our Open Devices initiative.

built kernel boot.img but failed boot

Highlighted
Message 1 of 2
2,198 Views
Message 1 of 2

built kernel boot.img but failed boot

Hello

I have build boot.img but my XZ1 cannnot boot, i see the logo SONY and that's it.

My script

cd /android/kernel/sony/msm/

export ARCH=arm64
export CROSS_COMPILE=aarch64-linux-android-
make aosp_yoshino_poplar_defconfig
make -j2

copy kernel to
/home/android/kernel/sony/msm/arch/arm64/boot

cd /android

source build/envsetup.sh && lunch (44)

export TARGET_PREBUILT_KERNEL=/android/kernel/sony/msm/arch/arm64/boot/Image.gz-dtb

make bootimage

and try
fastboot boot c:\temp\boot.img

but only logo

can anyone help me, I try many time but failed.

 

thanks

 

 

1 REPLY 1
Developer World
Message 2 of 2
2,179 Views
Message 2 of 2

Re: built kernel boot.img but failed boot

hi,

which android build guide are you using and which kernel version

 

Your device will not boot unless you flash all partitions for aops including the vendor that is mentioned in the build guide

 

Regards

Alin