account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Xperia E1 Dual stuck on Logo: green LED dissapear when connected to pc

One time poster
Message 1 of 1
Message 1 of 1

Xperia E1 Dual stuck on Logo: green LED dissapear when connected to pc

My Sony Xperia E1 Dual D2105 is stuck on Sony logo when I boot the device after it went off suddenly. It doesn't proceed any further.


I have tried to repair through Xperia Companion, but when i connect the device by usb while pressing volume down button the LED shows a red light then green light less than a second, the LED went off and nothing did show up. And XC says failed to repair.


A few seconds later the phone starts and it stops at the point where it shows 'sony' with red light LED flashes. It doesn't proceed any further.


I have tried to take out the battery, put it on again, plug while pressing volume down. But again, the same issue.


Also when I press volume down button and connecting the device to my pc, my pc doesn't recognise my phone.


I also tried to flashing my phone with flashtool, this thing has the same issue as I used XC.


Note: My phone's battery was fully charged


I thought it was hardware problem, but it seems okay till the device stuck on Sony logo, anyone please help me, what should I do?


Sorry for my bad English