account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

Xperia Z4 LTE camera issues

Highlighted
Apprentice
Message 1 of 9
660 Views
Message 1 of 9

Xperia Z4 LTE camera issues

Hi

 

I have a Sony Xperia Z4 LTE tablet which I encounter some issues with BOTH front and main cameras:

Whenever I take pictures with any other apps than the built-in camera app the image is flipped and dragged to the unrecognizable. This applies to facebook, snapchat or any other apps. However, the preview is fine and video mode is ok.

 

I have tried searching in here and elsewhere on the web but cannot find other people that has exactly the same issue, most people only appear to have problems with the messenger app and the answer to that is "app issues, not sony"

 

I have tried all settings regarding camera resolution, autorotate OFF etc.

I have even tried to factory reset the tablet twice. Last time I chose to set it up as a new tablet and download all apps again but with no success. 

 

Any advice?  I would like to try the Sony companion software repair but after the tablet is detected and I choose software repair it just stops at "initializing"

8 REPLIES 8
Apprentice
Message 2 of 9
658 Views
Message 2 of 9

Re: Xperia Z4 LTE camera issues

BTW, I am running Android 7.0 but the problem started with the previous sw version as well

Forum Legend
Message 3 of 9
648 Views
Message 3 of 9

Re: Xperia Z4 LTE camera issues

can you try to upload some sample images?

 

how about when you are on safe mode?

 

make sure to run Xperia Companion with admin privelages. when performing software repair using Xperia Companion... be patient as the program will download the whole software that might be almost 1Gb



________________________________________________________________________________
The Man! The Myth! The Forum Legend! -Scott Sterling
Apprentice
Message 4 of 9
641 Views
Message 4 of 9

Re: Xperia Z4 LTE camera issues

Hi, thanks for your reply.

Finally I successfully managed to factory reset the tablet now by using the Xperia companion software repair. Took a full 4 hours. *puh*.

But it still works the same way....

Attached are screenshots using Snapchat preview and after picture is taken.

Regarding safemode, I followed your link but it does not describe how to boot in safemode with android 7.0 tablet. I tried to switch the service off and then holding the volume down key whilst powering on but no success. 

 

ReScreenshot_20170702-211352.pngScreenshot_20170702-211400.pngScreenshot_20170702-211426.pngScreenshot_20170702-211437.png

Apprentice
Message 5 of 9
637 Views
Message 5 of 9

Re: Xperia Z4 LTE camera issues

Ok, so I found out how to boot in safe mode.

 

But then I cannot access any 3rd party apps which is what is my problem.

The built in camera app works fine but ANY other app that uses the camera causes it to flip/rotate.

 

It has been like this for several months now and I have updated all my apps on a daily basis and always run the latest android version. 

It is hard to believe that all these 3rd party apps share the same bug.

Forum Legend
Message 6 of 9
621 Views
Message 6 of 9

Re: Xperia Z4 LTE camera issues

hi @tggggretr, ok i see the problem.

part of this might be because of app incompatibility. (yes i know,. unlikely but still)

 

can you try with other camera app? like camera super pixel on google play

 

I will try to get some more information regarding this.



________________________________________________________________________________
The Man! The Myth! The Forum Legend! -Scott Sterling
Forum Legend
Message 7 of 9
619 Views
Message 7 of 9

Re: Xperia Z4 LTE camera issues

have you tried to toggle auto rotate?



________________________________________________________________________________
The Man! The Myth! The Forum Legend! -Scott Sterling
Apprentice
Message 8 of 9
614 Views
Message 8 of 9

Re: Xperia Z4 LTE camera issues

Hi 

Yes, toggle auto-rotate was actually one of the first things I tried and it does not make any difference.

 

The app "camera super pixel" on google play said it was not available for my device when I tried downloading it.

However, I tried a similar app called "HD camera ultra" and it actually performs as it should without flipping the image. 😎 Strange.. 🤔

 

I really appreciate your effort in trying to help me out here 👍

Apprentice
Message 9 of 9
582 Views
Message 9 of 9

Re: Xperia Z4 LTE camera issues

Hi again. I have still not resolved this issue. With regards to my previous post, this _may_ look like an app issue. This makes it even more frustrating as I have had this problem with my tablet for approximately 6 months now and none of the updates for snapchat, messenger or facebook has fixed this bug. If this is an app issue, then all other xperia z4 tablet owners must have the same problem with those apps then?