account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

Camera not working properly

Learner
Message 1 of 6
705 Views
Message 1 of 6

Camera not working properly

Hi.

 

I own an Xperia XZ1 Compact with Android 9.0 installed (Build Number 47.2.A.8.24).

Since 2-3 weeks my Camera is not working properly anymore -> "Camera not available" is the error message. After restarting the phone the camera starts working again... for some time.. and then the same error pops up again. 

 

I noticed that other Sony devices have that error also, see https://talk.sonymobile.com/t5/Xperia-Z1-Z1s/Error-Camera-not-Available/td-p/421571/page/10

and tried various mentioned solutions in that topic, like 

- Clearing Camera App Cache

- Trying out other Camera Apps

- Safe Mode...

 

None of them offered a longterm-working-solution. Any other ideas?

5 REPLIES 5
Highlighted
Emperor
Message 2 of 6
702 Views
Message 2 of 6

Re: Camera not working properly

@vaper85 

 

how about repairing the phone with Xperia companion?




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Sony Xperia Support
Message 3 of 6
688 Views
Message 3 of 6

Re: Camera not working properly

Hi @vaper85, sorry to hear about this. Slightly frowning Face

For how long is the camera working as it should after restarting your device? Is it a day or two or a week?

It would be very interesting if you could do the camera test in inbuilt Support application the next time this error message appears and see if the camera is available in the test or not. The test can be found in Settings > Support > Xperia tests > Camera.

If you have an SD card in your device, you can temporarily remove this and see if there is any change.

Keep us posted! Slightly smiling Face


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

Learner
Message 4 of 6
683 Views
Message 4 of 6

Re: Camera not working properly

Thank you Jonas & uliwooly for your replies.

 

Yes there is an 128GB SD Card in my device, i will remove it and try if it helps. If it doesn't work I will try the Software Repair. I will report if one the suggested solutions works.

 

@Jonas: the Camera is not working for long after a restart, usually it last only for a few minutes before becoming "not available" again. I just restarted the phone, Camera worked a few minutes and afterwards I tried the Camera test (under Settings -> Support -> Xperia Test > Camera): The test tells me the same "Camera not available"

Sony Xperia Support
Message 5 of 6
645 Views
Message 5 of 6

Re: Camera not working properly

Hi again @vaper85 and thank you for the update!

That sounds like a very good plan and keep us posted on how it went!


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

Learner
Message 6 of 6
642 Views
Message 6 of 6

Re: Camera not working properly

Tested without SD-Card: that error still happens. Didn't do Software repair though since I try to avoid setting everything up new.

What I also noticed is that battery drain increased