account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests with the support app directly on your phone.
Read more and discuss the app here.

Z5 compact vibrate/silent mode automatically turning off

One time poster
Message 1 of 3
Message 1 of 3

Z5 compact vibrate/silent mode automatically turning off

Hi everyone,


If I set my phone to vibrate only or one of the silent modes (including ones with no exceptions like Total Silence), the phone often seems to "take itself out" of this and revert to enabling notification sounds - sometimes I set it and within a few seconds either the vibrate or do-not-disturb icon just disappears from the notification bar! I can't figure out if it is the phone or a specific app that is doing this.


I found an old post for the Xperia mini but the solution (disable device administrators) only device administrators ticked are Xperia protection and android device manager, neither of which seem to be the cause of the problem. Does anyone know how to go about finding out if an app is causing the problem, and if so which one?



Message 2 of 3
Message 2 of 3

Re: Z5 compact vibrate/silent mode automatically turning off

could you test it in safe mode

"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Scavenger Hunt Winner
Message 3 of 3
Message 3 of 3

Re: Z5 compact vibrate/silent mode automatically turning off

2 things to check. Make sure you're not accidentally smashing volume up button or make sure its not shorting. That will cause you to leave silent mode and DND.


//----------------- C:\》$ Path- Thyme: .trawler //-----------------Auto-Correct Disclaimer: Not sorry. //----------------- Batteries not included.