account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Curious about what is happening at IFA?
Read more and discuss the press conference here.

Xperia Z Back, Home, and Recent App button not working

Highlighted
One time poster
Message 1 of 2
1,519 Views
Message 1 of 2

Xperia Z Back, Home, and Recent App button not working

Hello Support!

 

I'm encountering a problem with my Xperia Z

The Back, Home, And Recent App Buttons (buttons at the bottom of the touchscreen) are not working.

 

I don't know how it made it that way but it just did.

 

I've searched first some solutions like Safe mode booting, Service testing, Repairing Via PC companion, and Factory resetting but nothing works after I've done all of that.

 

I noticed that the touchscreen is working since When I used the Service tester for Touchscreen the area where these 3 buttons are located can be drawn. So I assume it's not my hardware causing the problem. I can't use the phone normally anymore I have to try so hard to exit my apps use rotate home screen to relocate the three buttons so that I can somehow use it.

 

I didn't jail break or root  the phone...(I'm against that ^_^)

 

Please help I've tried all possible DIY repair I can find from this forum....

 

I really need some reply ^_^

 

Cheers!

1 REPLY 1
Forum Legend
Message 2 of 2
1,506 Views
Message 2 of 2

Re: Xperia Z Back, Home, and Recent App button not working

Hi,

I'm sorry to hear that.
If you have tried all the things that you mention but they still doesn't work, it do sound more related to the hardware. Perhaps if you have a screen protector or similar attached, you could always try to remove it to see if it works. Otherwise, I suggest that you visit nearest service center to have the phone examined by a technician. You can contact your Local support for information about nearest service center and/or how to proceed with this in the best possible way.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.