account arrowhead-down arrowhead-up cart mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

Showing results for 
Search instead for 
Did you mean: 

Xperia Sola Update Bricked Phone!

One time poster
Message 1 of 3
Message 1 of 3

Xperia Sola Update Bricked Phone!


ive managed to update my xperia sola via SEUS, after SEUS finished downloading,

the software hanged and the phone didnt boot or anything.. then i tried to restart the phon but no success, then i unpluged the

phone and restart the phone, then what happened was the phone Stucked at a boot loop: off->SE Logo-> an "Exclamation+a phone" icon->Reset and this loop goes on and on..

i cannot stay in flash mode or fastboot mode more than 5 sec, the phone restarts!

the driver is installed i think (while before i installed Android ADB driver in device manager when was into fastboot mode or flashmode)

Please guide me its very important to me!


(win xp sp3)

Sony Xperia Support
Message 2 of 3
Message 2 of 3

Re: Xperia Sola Update Bricked Phone!

Try to reinstall it again using SUS. And if it won't stay in flash mode try to move the USB cable to another USB port on your computer.

One time poster
Message 3 of 3
Message 3 of 3

Re: Xperia Sola Update Bricked Phone!

Thanks for ur reply,

That ddint help, but only for other ppl im telling the story that how i finally solved that :-)

After a day when i was disappointly try to put it in flashmode it went into green light

Enough to use seus on it again, and in this time the down progressbar started to filling up,

When that reached the end of progress, the phone still was dead with a red light, even for 1hour!

I tried once again but the same, after thinkin alot i managed to download the stock firmware

As .ftf file and flash it using flashtool, it wasnt successful at the 1st try

But after turning off d phone and put it flashmode once again and flash it via flashtool, it got to install

The firmware and after that i manually restart the phone and.. Yeaahh i was in nice timescape UI again


Tnx for help btw.