account arrowhead-up cart mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-down

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.


Xperia S Lt26i NFC problem

One time poster
Posts: 1
Registered: ‎2012-09-22

Xperia S Lt26i NFC problem

I updated my xperia S to ICS firmware  6.1.A.2.45 with Flashtool. Everything is ok expect NFC. I cannot turn on NFC in my phone. It cannot be loaded. How can I do?

One time poster
Posts: 3
Registered: ‎2012-08-01

Re: Xperia S Lt26i NFC problem

Hi, im having the same problem now...

i would love to see an answer for it...

Posts: 87,539
Registered: ‎2010-07-03

Re: Xperia S Lt26i NFC problem

repair your phone with SUS and elaborate on your issue

Update Service (SUS)

Alternatives on How to backup Xperias

Don't forget to mark the Correct Answers & Helpful Answers

unrelated topic, if you have some time please check this thread

"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

One time poster
Posts: 3
Registered: ‎2012-08-01

Re: Xperia S Lt26i NFC problem

I tried it... i even reinstalled the version (and it deleted most of the information i had on the phone, fortunatly enough i backed up the phone before so i have most of the things back)...

it didnt solve the problem, im still unable to enable the NFC in my phone sad

One time poster
Posts: 20
Registered: ‎2011-08-15

Re: Xperia S Lt26i NFC problem


I too have the NFC issue - I can not turn it on.

Since ICS update the NFC will not activate.

I have tried the repair option 3 or 4 times over a couple of months and still no change.

It just won't turn on.

I check the NFC box under Wireless & Networks - the tick appears in the checkbox, the NFC box dulls to a light grey and 6 seconds later the checkbox unchecks and the NFC box goes back to the bright white font.

I have tried using the tools widget to turn on the NFC and all I get is a blue halo in the NFC box turning for about 5 seconds and then nothing.

Am I missing something or is there an underlying issue at work here?

I have also uninstalled AVG and rebooted the phone - this has also had no effect (although this didn't serve as an issue before the ICS update).

Please, somebody, anybody, can you help - hopefully it's something simple that'll leave me red faced....

Message was edited by: Drewboi I have just tried the NFC test in the hidden service menu - NFC Diag Test The NFC device can not be used. OK