account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests directly on your phone with the support application.
Read more and discuss the app here.

Worst phone I bought ever

Pc2
One time poster
Message 1 of 7
868 Views
Message 1 of 7

Worst phone I bought ever

I purchased a Sony Xperia t2ultra ... I recently upgraded to android lollipop 5.0 and the phone has stopped working it only display the following error

Unfortunately simple home has stopped
Pls return my money back ....
6 REPLIES 6
Emperor
Message 2 of 7
867 Views
Message 2 of 7

Re: Worst phone I bought ever

@Pc2

 

I'm sorry to hear that contact your local Xperia Care

 

http://support.sonymobile.com/global-en/contactUs/




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Highlighted
Sony Xperia Support
Message 3 of 7
837 Views
Message 3 of 7

Re: Worst phone I bought ever

Hi Pc2,

 

Welcome to the community.

 

I am sorry to hear about the issues you have had wth the handset. You may be able to load the device in to Safemode and then clear the data from the Simple Home app.

 

Safemode instructions

 

To clear Simple home data when in Safemode,

 

Menu > setting's > Apps  > all  > Simple Home > Clear Data,

 

Once done restart the handset and see what happens.

 

Let us know how you get on.


Official Sony Xperia Support Staff


If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

One time poster
Message 4 of 7
807 Views
Message 4 of 7

Re: Worst phone I bought ever

Hi guys, I am also having this issue, after installing the latest update from Sony.  I tried booting in safe mode, but when I enter my pin it takes me to a blank screen and the error comes up again.  I cannot get into any menus or apps or settings.  Help - I've only had this phone for 4 days and I really need it to work.

 

UPDATE - I managed, in between the annoying message constanly appearing, to swipe the status bar down and get into quick settings, which allowed me to go and clear the cache for this app.  It appears to now be working - hopefully will continue. 

Visitor
Message 5 of 7
770 Views
Message 5 of 7

Re: Worst phone I bought ever

Hi

 

I think you updated your phone directly from your phone ,i did  that thing i got the same problem i went to Service center they updated the os its ok now that prblm got clered ,so goto service center

Emperor
Message 6 of 7
740 Views
Message 6 of 7

Re: Worst phone I bought ever

@AussieJo

 

keep us updated




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Rookie
Message 7 of 7
616 Views
Message 7 of 7

Re: Worst phone I bought ever

Wow easy for update and no root