account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Very strange issue with flash (not the flash-bleeding issue)

Highlighted
Visitor
Message 1 of 4
1,036 Views
Message 1 of 4

Very strange issue with flash (not the flash-bleeding issue)

 Hi everyone.

 

I have a strange problem: I can only use the camera flash one time, if I want to use it again I have to restart the phone.

 

In depth:

  1. I boot the phone.
  2. I can use the torch mode without problems as many times as I want
  3. I open the camera app and I set the flash mode to auto/forced.
  4. I take a picture. Flash is fired.
  5. The phone makes the same noise as if I plug the usb connector to charge it.
  6. I take a another picture. Flash is not fired. Torch mode is not working. Charging is not working.
  7. Reboot the phone
  8. Go to 1

I already tried to reset the device to factory, delete caches, wipe the entire phone…Anyone knows more about this problem?

 

Thanks!

3 REPLIES 3
Moderator
Message 2 of 4
1,033 Views
Message 2 of 4

Re: Very strange issue with flash (not the flash-bleeding issue)

Seems a strange one, have you contacted your local support to see what they say?


Moderators are not affiliated with, or work for Sony Mobile, and their posts represent their own opinions and views.
Click here to find out more about the different roles on the community.

Moderator
Message 3 of 4
1,030 Views
Message 3 of 4

Re: Very strange issue with flash (not the flash-bleeding issue)

Also, check the USB port for fluff and other debris.


Moderators are not affiliated with, or work for Sony Mobile, and their posts represent their own opinions and views.
Click here to find out more about the different roles on the community.

Visitor
Message 4 of 4
1,017 Views
Message 4 of 4

Re: Very strange issue with flash (not the flash-bleeding issue)

Yes, few hours ago I have sent an email thru the support form. I will post any possible solution here.

Fingers crossed..