account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Want to know more about Xperia 5? To read more about it go here.
If you can't find the answer to your question there please post it here and let the community help you.

Tablet Z doesn´t charge anymore

One time poster
Message 1 of 8
Message 1 of 8

Tablet Z doesn´t charge anymore

Hi there,


I have a Tablet Z Experia since May 2013 (SGP311 Model /Wifi only) used it the other day with almost full battery (first one) for about 2-3 hours. Battery ran down to about 12%. then tried to hook it on charge but it´didn´t respond. No charging.. checked the cable with another device and it charged fine.. tried other cables on the wall socket, nothing works.... battery has run down to 1% and has died since... also tried the power + loudness 10second drill, nothing... now when I press the button the red light flashes 3times and that´s it....


also tried to put it on PCC and do the repair, but the PC won´t recognize it anymore....


Any help here.. or is the only option to send it to repair??!! :-(





Message 2 of 8
Message 2 of 8

Re: Tablet Z doesn´t charge anymore



Try this 


connect the tablet to a wall charger > press and hold power & volume up for 10 seconds > let it charge for 2-3 hours then repair it with PCC

"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Message 3 of 8
Message 3 of 8

Re: Tablet Z doesn´t charge anymore

If indeed the charge port is broken you could try getting a charging dock which uses a separate circuit.

Moderators are not affiliated with, or work for Sony Mobile, and their posts represent their own opinions and views.
Click here to find out more about the different roles on the community.

Sony Xperia Support
Message 4 of 8
Message 4 of 8

Re: Tablet Z doesn´t charge anymore

Hi Skyduck55,


Welcome to the community,


Failing the software repair, I can only really suggest having the device checked out by a service agent.


Use my signature below to find contact details if needed.

Official Sony Xperia Support Staff

If you're new to our forums, make sure that you've read our Discussion guidelines.

To get in touch with your local support team, please visit our contact page.

Message 5 of 8
Message 5 of 8

Re: Tablet Z doesn´t charge anymore

Nothing broken, just an important mistake in the project:

if the battery is zero, the charge does not start because the microprocessor that manage the charge is not powered.

So the LED turns on for few second but then turns off again.

If you are lucky and the last three or four electrons are able to flow, it starts, if not, it is dead.

I found a quite simple solution, leave the USB charger connecten and at the same time with another power supply 6Vdc I did give power to the two wires of the dock, + on the power button side; just one second to wake up the system, than the charge starts.

I think there is not solution, hardware limit.

Just do not let dischage it completely, set the power manager to switch off the Z at 10%, and use it sometimes

Message 6 of 8
Message 6 of 8

Re: Tablet Z doesn´t charge anymore

You sir are a genius!


Your solution worked fine on the Xperia Z Tablet 10.1 I have here and I have another one at home with exactly the same problem.


The short version is:

Plug tablet into power via wall charger

Since it is impossible to source a dock, cut up a different USB cable to expose red and black wires

While plugged in, touch the red and black wires to the dock terminals - red to terminal near power button (+ive)


After a few seconds it booted up fine and is now charging via the regular cable.

Message 7 of 8
Message 7 of 8

Re: Tablet Z doesn´t charge anymore

Thank you very much I don't have sound on my tablet for a long time only had sound the first few months do you perhaps know what i can do please
Message 8 of 8
Message 8 of 8

Re: Tablet Z doesn´t charge anymore

No idea with the sound, sorry.  The 5 tablets we have here are mainly used by technicians in the field for our forms.  We don't use sound so I couldn't say if ours are working or not.


If the headphones work and the speakers don't I would google further to see if its a common problem.  Otherwise I can't help.