account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Want to know more about Xperia 5? To read more about it go here.
If you can't find the answer to your question there please post it here and let the community help you.

Sony Xperia ZR wifi stopped working, then starts working again (NOT!)

Highlighted
Adviser
Message 1 of 34
17,309 Views
Message 1 of 34

Sony Xperia ZR wifi stopped working, then starts working again (NOT!)

After a week of being a happy Sony Xperia ZR (4.1.2, C5502) owner, my wifi stopped connecting to networks. I can't connect to any network I have tried, but the list of networks is ok. It stopped working suddenly. My previously used networks are all marked as "Saved", but when I try to connect the following happens:

 

1) Saved (doesn't even change when tapped)

2) Connecting -> Saved

3) Connecting -> Authentication problem -> Saved

 

After half day without wifi, this is what I have tried to fix it:

 

1) Restart phone

2) Restart phone, take out battery, SD card and SIM card

3) Restart wi-fi router

4) Connect to another network

5) Forget network -> Type password again

6) Connect another Android device to the same network

7) Connect another non-android device to the same network

8) Sony Companion -> Repair

 

Nothing fixed the issue, still the same problem. And now the grand finale:

 

I packed the phone into the box and went to cook a delicious stew which took about 3 hours and filled my apartment with heavenly smelling goodness. I came back to check whether there are any data in the phone and it started to work again. Just like that. I did not do anything.

 

Now please anyone tell me, is this going to happen often? Because if so, I am going to make a youtube video "How many hits by hammer can Sony Xperia ZR take" and buy HTC One.

 

Also if anyone wants the recipe for the stew, let me know.

 

EDIT: It worked until it lost connection. I have discovered that sometimes it works, but immediately after losing connection, back to square one. So far I've tried about 15 different wi-fi routers and networks.

33 REPLIES 33
Adviser
Message 2 of 34
17,274 Views
Message 2 of 34

Re: Sony Xperia ZR wifi stopped working, then starts working again

It worked for a while and now I am back to having no wifi. Just a list of networks and authentication problem. I've also tried disconnecting all the other devices and connecting the phone alone. No luck. Sigh. Where is my camera and the hammer...

Sony Xperia Support
Message 3 of 34
17,273 Views
Message 3 of 34

Re: Sony Xperia ZR wifi stopped working, then starts working again

I saw another user having a similar problem in another thread and it turned out to be a hardware problem in that phone. As the problem remains after a repair of the phones software i suspect that this is the case also with your phone.

I would suggest that you contact a service location or local Sony Xperia support (http://www.sonymobile.com/global-en/support/contact-us/) for assistance.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Visitor
Message 4 of 34
17,255 Views
Message 4 of 34

Re: Sony Xperia ZR wifi stopped working, then starts working again

Hello!

I have the same issue with Sony Xperia ZR (4.2.2, C5503)

During first 3 weeks wi-fi worked perfectly. 

And suddenly I had problems connecting wi-fi at work: there were a list of wi-fi APs but I could not connect to any of them.

In the evening wi-fi at home worked normaly. Next day I could not connect to neither home wi-fi nor wi-wi at work. 

 

After factory resetting phone several times  I've tried to downgrade to Android 4.1.2 than upgrade to Android 4.2.2 again. Nothing help. 

 

 

Sam
Sony Xperia Support
Message 5 of 34
17,243 Views
Message 5 of 34

Re: Sony Xperia ZR wifi stopped working, then starts working again

Do you get any specific error message when trying to connect to the access points?

 

 


 

 

What are your thoughts about this forum? Let us know by doing this short survey.

sony_sign_logo.png - Official Sony Xperia Support Staff


If you're new to our forums make sure that you have read our Discussion guidelines.
If you want to get in touch with the local support team for your country please visit our contact page.

Adviser
Message 6 of 34
17,237 Views
Message 6 of 34

Re: Sony Xperia ZR wifi stopped working, then starts working again

Here's information about the phone and logcat from the time of wifi on to first failure. It looks like something is wrong with wpa_supplicant (the networks are WPA2).

 

Build number:
10.1.1.A.1.310

Kernel:
3.4.0-g6df7905-02327-g1aa3092
BuildUser@BuildHost) )
#1 SMP PREEMPT Thu Apr 11 11:17:13 2013

 

09-18 09:10:08.116: I/WifiManager(2391): Process ndroid.settings enabled Wifi
09-18 09:10:08.186: E/WifiHW(571): File "/data/misc/wifi/WCNSS_qcom_cfg.ini" exists, not copying
09-18 09:10:08.497: I/wpa_supplicant(3838): nl80211: Don't connect to APs with RSSI < 0
09-18 09:10:08.497: I/wpa_supplicant(3838): rfkill: Cannot open RFKILL control device
09-18 09:10:08.497: I/ActivityManager(571): No longer want com.google.android.onetimeinitializer (pid 1747): hidden #51
09-18 09:10:08.637: I/wpa_supplicant(3838): wapi_supplicant_init: Init WAI packet p2p0
09-18 09:10:08.637: I/wpa_supplicant(3838): Own MAC address: (Here's phone MAC address)
09-18 09:10:08.637: E/wpa_supplicant(3838):  Initialization: WAPI:set Staues=1
09-18 09:10:08.657: E/Diag_Lib(3838):  Diag_LSM_Init: Failed to open handle to diag driver, error = 13
09-18 09:10:08.757: E/wpa_supplicant(3838):  QMI_UIM_EVENT_REG_REQ_V01, qmi_err_code: 0x0
09-18 09:10:08.777: E/wpa_supplicant(3838): QMI_UIM_GET_CARD_STATUS_REQ_V01, qmi_err_code: 0x0
09-18 09:10:08.777: E/wpa_supplicant(3838): card_info[i].card_state: 0x1
09-18 09:10:08.777: E/wpa_supplicant(3838): card_info[i].error_code: 0x0
09-18 09:10:08.777: E/wpa_supplicant(3838): card READY
09-18 09:10:08.777: E/wpa_supplicant(3838): card_info[i].app_type : 0x2
09-18 09:10:08.777: E/wpa_supplicant(3838): card_info[i].app_state : 0x7
09-18 09:10:08.777: E/wpa_supplicant(3838): card found
09-18 09:10:08.797: I/wpa_supplicant(3838): Reading GSM home network domain configuration file '/system/etc/wifi/gsm_domains.conf'
09-18 09:10:08.877: I/wpa_supplicant(3838): nl80211: Don't connect to APs with RSSI < -83
09-18 09:10:08.877: I/wpa_supplicant(3838): rfkill: Cannot open RFKILL control device
09-18 09:10:08.917: I/wpa_supplicant(3838): wapi_supplicant_init: Init WAI packet wlan0
09-18 09:10:08.917: I/wpa_supplicant(3838): Own MAC address: (Here's phone MAC address)
09-18 09:10:08.917: E/wpa_supplicant(3838):  Initialization: WAPI:set Staues=1
09-18 09:10:08.957: E/wpa_supplicant(3838):  QMI_UIM_EVENT_REG_REQ_V01, qmi_err_code: 0x0
09-18 09:10:08.977: E/wpa_supplicant(3838): QMI_UIM_GET_CARD_STATUS_REQ_V01, qmi_err_code: 0x0
09-18 09:10:08.977: E/wpa_supplicant(3838): card_info[i].card_state: 0x1
09-18 09:10:08.977: E/wpa_supplicant(3838): card_info[i].error_code: 0x0
09-18 09:10:08.977: E/wpa_supplicant(3838): card READY
09-18 09:10:08.977: E/wpa_supplicant(3838): card_info[i].app_type : 0x2
09-18 09:10:08.977: E/wpa_supplicant(3838): card_info[i].app_state : 0x7
09-18 09:10:08.977: E/wpa_supplicant(3838): card found
09-18 09:10:09.037: E/WifiConfigStore(571): Failed to look-up a string: W
09-18 09:10:09.037: E/WifiConfigStore(571): Failed to look-up a string: SMS4
09-18 09:10:09.037: E/WifiConfigStore(571): Failed to look-up a string: SMS4
09-18 09:10:09.077: I/WifiManager(2391): Process ndroid.settings requested an active scan
09-18 09:10:09.087: E/Parcel(334): Reading a NULL string not supported here.
09-18 09:10:09.087: E/Parcel(334): Reading a NULL string not supported here.
09-18 09:10:09.097: E/Parcel(334): Reading a NULL string not supported here.
09-18 09:10:09.097: I/SuperStamina-WifiAnalyzer(571): WiFi is ON.
09-18 09:10:09.117: E/wifidirect(3726): onStartCommand 1
09-18 09:10:09.117: E/wifidirect(3726): Exitting file transfer service.
09-18 09:10:09.117: W/wpa_supplicant(3838): wlan0: Failed to initiate AP scan
09-18 09:10:09.117: W/wpa_supplicant(3838): p2p0: Failed to initiate AP scan
09-18 09:10:09.127: E/wifidirect(3726): onStartCommand 1
09-18 09:10:09.127: E/wifidirect(3726): Exitting file transfer service.
09-18 09:10:10.128: W/wpa_supplicant(3838): wlan0: Failed to initiate AP scan
09-18 09:10:11.119: W/wpa_supplicant(3838): wlan0: Failed to initiate AP scan
09-18 09:10:12.130: W/wpa_supplicant(3838): wlan0: Failed to initiate AP scan
09-18 09:10:12.811: I/wpa_supplicant(3838): wlan0: Trying to associate with (here is my router MAC) (SSID='smartus@unifi' freq=2427 MHz)
09-18 09:10:14.023: I/wpa_supplicant(3838): wlan0: CTRL-EVENT-ASSOC-REJECT bssid=(here is my router MAC) status_code=1
09-18 09:10:19.088: I/WifiManager(2391): Process ndroid.settings requested an active scan
09-18 09:10:22.812: I/wpa_supplicant(3838): wlan0: Authentication with (here is router MAC) timed out.

Adviser
Message 7 of 34
17,164 Views
Message 7 of 34

Re: Sony Xperia ZR wifi stopped working, then starts working again

Tried another three wi-fi routers. All of them reply CTRL-EVENT-ASSOC-REJECT, but one of them works sometimes. I believe the phone is either sending something wrong and is really being rejected or the fault is that is wrongly interprets the messages from the router.

 

I checked wpa_supplicants sources and found out that this message usually happens when the network is congested and another user on anotherf forum found out that it might be caused by certificates in case of WPA. Unfortunately it happens when using unsecured and WEP as well.

Adviser
Message 8 of 34
17,101 Views
Message 8 of 34

Re: Sony Xperia ZR wifi stopped working, then starts working again

I have done more testing then took it to service centre. They confirmed HW problem. Full story here. Will update it if it happens again.

Visitor
Message 9 of 34
17,083 Views
Message 9 of 34

Re: Sony Xperia ZR wifi stopped working, then starts working again

Please keep updated about results.
I have exactly the same issue with my Xperia XR, service center confirmed that was hardware issue. But the did not find out what exactly is broken.

Adviser
Message 10 of 34
16,943 Views
Message 10 of 34

Re: Sony Xperia ZR wifi stopped working, then starts working again

I have new phone as you can read in the blog entry I linked. After a month still working fine.