account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

If you want to get the max out of your Xperia phone then check out Xperia tips page.

Sony Xperia Z1 not detecting headset again

Rookie
Message 1 of 9
1,657 Views
Message 1 of 9

Sony Xperia Z1 not detecting headset again

Once more after a software update my Sony Xperia Z1 is not detecting the headset. I think this is the fourth og fifth time in one year the same bug occurs. When connecting the headset the sound is directed to the loudspeakers and not the headset. After a phone restart it works ok for some hours.

It seems like an old bug is introduced almost every time a software update is released.

The Z1 is an excellent phone. But this repetitive bug is very annoying... 

8 REPLIES 8
Rookie
Message 2 of 9
1,648 Views
Message 2 of 9

Re: Sony Xperia Z1 not detecting headset again

Extra information:

  1. I know see that connecting the headphones only works OK first time after restart. After first connect/disconnect the phones does not detect the headphones and I have to restart the phone to be able to get the music directed to the headset.
  2. I have tried to deactivate Smart Connect. Same problem.
  3. Have tried with several different headsets. Same problem.
Message 3 of 9
1,611 Views
Message 3 of 9

Re: Sony Xperia Z1 not detecting headset again

Yes that is a bug I am also facing that problem. I am using klipsch earphone that works well before kitkat.
The problem is, when I connect earphone that comes with z1 that works perfectly( plugged in or out many times no problem).
But when I connect klipsch earphone that works only once. I have to restart mobile every time.
1. When I plugged in klipsch earphone then sound works well, but when I plugged out and reinsert klipsch earphone then sound comes from z1 speaker, not in klipsch earphone. Then I insert z1 earphone but sound comes from z1 speaker. I have to restart mobile to get sound again in earphone.
2. Then I try xperia mini earphone, z1 displayed message unsupported earphone and then I insert z1 earphone then same problem sound comes from z1 speaker not z1 earphone.
So when I insert any unsupported earphone then I have to restart mobile to get sound in z1 earphone.
Visitor
Message 4 of 9
1,582 Views
Message 4 of 9

Re: Sony Xperia Z1 not detecting headset again

I have the exact same problem! QwQ The earpeices will only play after the first time I restart, then I unplug it and reinsert, the sound will only come out from the speaker. Tried deleting Smart connections too and did not work. At first I thought there is water in my phone or other hardware issues...but now that it's a bug I hope Sony will release a fix soon.

One time poster
Message 5 of 9
1,520 Views
Message 5 of 9

Re: Sony Xperia Z1 not detecting headset again

I have the same problem with my Bowers & Wilkins P5 :'( And strangly other headphones (i tried with a Logitech G430 and a Sony ZX300) works on my Z1.

Regular
Message 6 of 9
1,502 Views
Message 6 of 9

Re: Sony Xperia Z1 not detecting headset again

Same issue, sometimes the phone refuses to recognise the headphones and sound is played over the speaker. After a restart it works again.

It's nice when this happens in a full train and I'm in the evil black metal part of my library Winking Face
Rookie
Message 7 of 9
1,494 Views
Message 7 of 9

Re: Sony Xperia Z1 not detecting headset again

First time I discovered it was 0630 in the morning on the train while (trying to) playing Frank Zappa.

Since I did not hear the music I continued to increase the volume. Not so popular... Slightly frowning Face

Highlighted
Visitor
Message 8 of 9
1,471 Views
Message 8 of 9

Re: Sony Xperia Z1 not detecting headset again

I factory resetted by phone and does not help...does any one know if the repair in PC companion will fix this issue? This is seriously annoying because I often need to use my phone for music.

Message 9 of 9
1,460 Views
Message 9 of 9

Re: Sony Xperia Z1 not detecting headset again

No, I fully repaired my z1 with PC Companion by using volume key down(it downloads latest firmware and fully repair firmware with new fresh copy) but problem is same. It is a kitkat bug.