account arrowhead-down arrowhead-up mobile-menu search sm-bold-x x-skinny-rounded x-skinny arrowhead-right social-facebook social-googleplus social-instagram social-linkedin social-pinterest social-qzone social-renren social-tencent social-twitter social-vkontakt social-weibo social-youku social-youtube

Please help us improve our website

Take our customer survey to evaluate your visit.

It should only take a few minutes to answer five quick questions. Just click the Launch survey button at the end of your visit to begin.

cancel
Showing results for 
Search instead for 
Did you mean: 
Tips & Tricks

Troubleshoot, find support articles, run tests with the support app directly on your phone.
Read more and discuss the app here.

Screen muticolor pixels after charging

One time poster
Message 1 of 3
1,322 Views
Message 1 of 3

Screen muticolor pixels after charging

Hi,

after charing the tablet, the screen is "broken". There are only multicolor pixels all over the screen. Cant do anything. Restart works, vibration too but always the same screen.

Connection via companion not really possible because it must be changed to "data transfer mode". Not possible without using screen.

 

Z3TabletJPG

Any ideas?

 

Greetz

2 REPLIES 2
Emperor
Message 2 of 3
1,313 Views
Message 2 of 3

Re: Screen muticolor pixels after charging

I'm sorry to hear that, you will have to contact your Local support regarding this.




"I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

Learner
Message 3 of 3
1,278 Views
Message 3 of 3

Re: Screen muticolor pixels after charging

How did this happen? 

How long have you had this device? 

Did you submerge it into water at all during your possession? 

Did your tablet fall down at all at any time before this?

Did you use official Sony charger? 

Did you root your device? 

Is it under warranty? 

 

This looks like a broken motherboard to me